Question I built what should be an awesome gaming PC but it's running like crap. I suspsect the motherboard but could use some help.

Mar 28, 2020
4
0
10
0
Motherboard: MSI MPG X570 GAMING EDGE WIFI Gaming Motherboard AMD AM4 SATA 6Gb/s M.2 USB 3.2 Gen 2 HDMI ATX

CPU: AMD Ryzen 7 3700X

RAM: 32gb


Basically everything runs extremely slowly. It takes minutes to boot up even with an SSD. About 60% of the time, the BIOS doesn't recognize mouse or keyboard. I've tried to update the BIOS to see if that would fix anything, but whenever I go to the BIOS flash page with the update file correctly placed on a USB drive, the flash page only sees directories on the drive, not individual files.

Also, the built in WiFi rarely works. Do I just have a bad mobo or is there something I haven't tried yet that could fix these issues?

Any help is appreciated.
 

kanewolf

Titan
Moderator
Motherboard: MSI MPG X570 GAMING EDGE WIFI Gaming Motherboard AMD AM4 SATA 6Gb/s M.2 USB 3.2 Gen 2 HDMI ATX

CPU: AMD Ryzen 7 3700X

RAM: 32gb


Basically everything runs extremely slowly. It takes minutes to boot up even with an SSD. About 60% of the time, the BIOS doesn't recognize mouse or keyboard. I've tried to update the BIOS to see if that would fix anything, but whenever I go to the BIOS flash page with the update file correctly placed on a USB drive, the flash page only sees directories on the drive, not individual files.

Also, the built in WiFi rarely works. Do I just have a bad mobo or is there something I haven't tried yet that could fix these issues?

Any help is appreciated.
Was this a clean OS install when you built it?
 

ASK THE COMMUNITY

TRENDING THREADS