• Enter here for a chance to win a custom MechWarrior 5: Mercenaries themed PC powered by Intel!

[SOLVED] I can only start the pc when the PSU to Mobo power cable is only half plugged in

Jul 23, 2020
1
0
10
0
So if the psu to mobo power cable is fully plugged in then pc simply won't start,it doesn't get power but i can still see that the leds are lit.
If i half plug out the psu to mobo power cable then i can start it and then i can fully plug in the cable and it works then.
In the news 5-10 minutes i can start it with a fully plugged cable but after i need to do the half plug thing again.
Yesterday when i tried to start the pc i heard three beep sounds and it didn't start, then i tried again and it started.I read that the three beep sound means a problem with memory, but im not sure thats the problem, thinking my mobo or psu is dying.


My mobo is an Asrock B360 fatality
PSU is a cooler master MWE650
 
So if the psu to mobo power cable is fully plugged in then pc simply won't start,it doesn't get power but i can still see that the leds are lit.
If i half plug out the psu to mobo power cable then i can start it and then i can fully plug in the cable and it works then.
In the news 5-10 minutes i can start it with a fully plugged cable but after i need to do the half plug thing again.
Yesterday when i tried to start the pc i heard three beep sounds and it didn't start, then i tried again and it started.I read that the three beep sound means a problem with memory, but im not sure thats the problem, thinking my mobo or psu is dying.


My mobo is an Asrock B360 fatality
PSU is a cooler master MWE650
Well, that certainly points to bad connector either on MB or PSU.
 
Reactions: Phillip Corcoran
So if the psu to mobo power cable is fully plugged in then pc simply won't start,it doesn't get power but i can still see that the leds are lit.
If i half plug out the psu to mobo power cable then i can start it and then i can fully plug in the cable and it works then.
In the news 5-10 minutes i can start it with a fully plugged cable but after i need to do the half plug thing again.
Yesterday when i tried to start the pc i heard three beep sounds and it didn't start, then i tried again and it started.I read that the three beep sound means a problem with memory, but im not sure thats the problem, thinking my mobo or psu is dying.


My mobo is an Asrock B360 fatality
PSU is a cooler master MWE650
Well, that certainly points to bad connector either on MB or PSU.
 
Reactions: Phillip Corcoran

ASK THE COMMUNITY

TRENDING THREADS