Question I can't boot up my computer!

Jul 17, 2019
1
0
10
0
Yesterday I tried messing around with my storage devices, because I could not find my SSD in my folders. Well, after messing around in disk management for a while, I was able to get the SSD to show! After a while of gaming I turned off my computer for the night. The next day when I tried to boot up, my computer gave me a message, reading, "'testapp.nsh' is not recognized as an internal or external command, operable program, or script file.

ERROR: Bootable EFI System Partition not found!
No operating system is installed, OS is corrupt, or a tiered disk is missing."

I tried restarting the computer and going into the BIOS to boot from other devices. When booting from the other options, it gave me "An operating system wasn't found. Try disconnecting any drives that don't contain an operating system. Press Ctrl+Alt+Del to restart"

I managed to get a windows 10 ISO download onto a USB drive and boot up my computer that way. It didn't let me enter Windows 10, only the option to install windows or use some of the troubleshooting, and none of the advanced troubleshooting worked, but I was able to get into the command prompt. The worst part is, I can't even remember what I did yesterday, but I know it has to do with my disks. Can anyone please help me!

If it makes it easier, I'd love to post photos of different places I go on command prompt, as soon as someone tells me how to upload pictures of my desktop screen from my phone/laptop, (considering I can't even log into windows on my desktop at the moment!)
 

Wheel in the Sky

Honorable
Aug 17, 2013
65
4
10,535
0
I don't think you can take screenshots without an OS or any software, so I guess you would have to take pictures of the screen with your phone.

Do you back up your computer at all?

Just to be clear, is your Windows installed on the SSD? You said you tried to boot from other devices...

You could try web searching your error message about testapp.nsh for some guidance. It's hard to say what the problem is if all you know is that you were messing around in Disk Manager.

Perhaps you changed the drive letter of your SSD? Although if that's where you Windows is, that shouldn't be possible because your boot drive always has to be your C: drive in Windows. I don't think Disk Manager will let you delete important partitions from the drive you are booted from either...
 

ASK THE COMMUNITY

TRENDING THREADS