I can't change my IDE configuration



I am running Windows 2000 on an Epox KT133Pro motherboard with Via KT133a chipset. I currently have a hard drive on my primary master and a cd writer on my secondary master and hard drive on my secondary slave. I tried to change the configuration around (to get everything to fit better in my case) and each time I change the configuratiopn of the IDE drives (even just unplugging the CD writer or secondary slave hard disk), my computer won't boot up: I get an invalid boot or system disk message. I have mucked around with bios and jumper settings heaps and am pretty sure (85%) this is not the reason for my problems (in the past using Windows 98 I have had no problems). Does anyone have any ideas why this might be happening and what I can do to enable the computer to let me change the IDE configuration? I have posted this message on the hard drive message board and someone suggested it could be a Windows 2000 problem as they had seen something similar on Win NT. I am pretty sure I chose FAT32 as the file type when I installed Windows 2000 and I have Win 98 on the secondary slave hard drive and I am given a choice of OS to boot to when I turn on the computer.


Jul 11, 2001
I've heard of this problem before. Probobly you have to change the boot.ini file, to reflect the changes you do with the hardware.
Also, you can try to change the boot-order in bios, that can also help (according to this guy I heard it from).