Question I can't get a microphone to work at all ?

Feb 22, 2023
So this maybe a motherboard issue, so I did reach out to asrock support and they said to request an rma and they will replace it. But considering the board is 3 months old, I feel there may be an issue and they'd wanna just charge me and send me the broken board back. So here goes.

Asrock z690 Pro RS
12700kf @ stock
16GB Vengeance Pro RAM
RX 570 4gb
NZXT H7 Elite case

First off, the motherboard + build I originally had, had no issues with my headphones and no microphone issues. I have also tried 3 different headsets, one being a pare of generic Apple wired headphones (with 3.5mm jack), 2 being the same thing as first, and 3rd being a Razer Kraken headset, which I know the mic works on, as I have used that pair on my phone w/out any issues.

What iv tried other then headphones: (yes iv tried everything with all headsets), different programs, different settings enabling/disabling the microphone on different programs, disabling and re enabling in advanced audio menu under recording, different audio channels under the advanced audio window, disabling all other inputs and setting the current one (being the one im trying to get the mic working on) to default. I have also tried Front audio 3.5mm (I know it works, as iv had a previous build in it too, and the microphone worked in it. Rear audio (connected directly to motherboard io ports), all 3 ports and all headsets, also tried a 3.5mm to microphone/stereo splitter and spent like an hour trying every combination back there. (being connected to the motherboard directly was also tried). I have tried multiple programs too, like discord, and some others. Settings doesn't even pick it up either. I have also tried drivers, installing the motherboard utility, the realtek audio, and some others. After about 2 months of trying, as iv given up on ideas to try.

if I can get help of any kind with this, it would be greatly appreciated.

-Evan or 1ava whatever u wanna call me