• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question I can't reformat my USB (16 gigabytes)!

May 4, 2020
Hello, I'm new to this forum. :)
I have a question about my USB drive.
Recently I purchased a 16 Gigabyte USB Drive to create a "Windows Boot USB." (Using "Windows Media Creation Tool) I put the USB into my computer and tried using it to create the boot USB. But after a couple minutes of it in the process of creating the windows installation, it said there was an error. I tried opening the USB drive but I realized that it got formatted and now, I can't open, reformat the drive. I have done multiple hours of research and found nothing. Which left me a "corrupt USB" and out some money. So I decided to find an answer here!
I hope you know how to fix it, or can help me.

- Akitzu
My System:

i5-2400 3.10ghz
8 Gigs of RAM
(I'm saving up to upgrade this potato) ;-;