Question I don't know if my motherboard is dead or not?

May 7, 2020
4
0
10
0
So I just bought my motherboard a month ago (Asus Prime B450M-A/CSM) mind you I never tested it because I didn't have a power supply to test anything I just bought a power supply and I am ready to test to see if my fans work also mind I don't have a cpu or ram yet I plugged in every connecter and all the screws and standoffs are in correctly I don't know if my motherboard is doa but I plug the 24pin connecter in and the cpu connecter and I switch the power supply on and try to press the power button on the case and nothing happens I have all the front io panel connecters all connected correctly the hdd led light shows up on the case when I plug it in to the mother board but still no fans turn in I have a fan hub which uses sata those don't turn on either neither does my fan connected to my fan header on my motherboard mind you I tried jumping the pins and nothing I plug my keyboard and mouse Into the rear io and switch on the PSU and they light upbut nothing with the motherboard and fans I did the paper clip method with the 24pin and I had my CPU connecter connected and sata power cable to the fans and it turned right on I'm not sure if my Mobo is dead or not it powers my periphials and a light on my case but nothing with the fans or fan on the Mobo unless I use paper clip method inside of 24oin connecter
 
So I just bought my motherboard a month ago (Asus Prime B450M-A/CSM) mind you I never tested it because I didn't have a power supply to test anything I just bought a power supply and I am ready to test to see if my fans work also mind I don't have a cpu or ram yet I plugged in every connecter and all the screws and standoffs are in correctly I don't know if my motherboard is doa but I plug the 24pin connecter in and the cpu connecter and I switch the power supply on and try to press the power button on the case and nothing happens I have all the front io panel connecters all connected correctly the hdd led light shows up on the case when I plug it in to the mother board but still no fans turn in I have a fan hub which uses sata those don't turn on either neither does my fan connected to my fan header on my motherboard mind you I tried jumping the pins and nothing I plug my keyboard and mouse Into the rear io and switch on the PSU and they light upbut nothing with the motherboard and fans I did the paper clip method with the 24pin and I had my CPU connecter connected and sata power cable to the fans and it turned right on I'm not sure if my Mobo is dead or not it powers my periphials and a light on my case but nothing with the fans or fan on the Mobo unless I use paper clip method inside of 24oin connecter
It's all for nought if you don't have CPU and RAM
 

ASK THE COMMUNITY

TRENDING THREADS