Question I get black screen after a few minutes of some games, but music does not stop

Mar 6, 2019
7
0
10
0
Good day everyone, I have a problem with my build. I bought this build a couple months ago and i solved many of the problems by myself but for this problem i could not anything spesific.

So my problem is when i start to play some games, my display just goes black after a nanosecond of freezing, and monitor says ''no display'' like my pc is not on. But the PC is actually continues to work, since i can both hear the fans and the whatever background music is playing is continues to play. I thought it would be a graphic card issue which somehow my build does not have the required spesifications but i tested on Star Wars Fallen Order, and i played it without a problem, infact i played it for at least 6 hours and no problem occured.

Then i tried to play Civ V, could not even make it into actual game. Or Fallout 4, No chance. Sometimes i got the same problem on Dying Light and They are Billions. So i started to check online and found out my drivers may causing these problems. therefore i downloaded the latest recommended Graphic card driver and uninstalled the old one and installed the new one.
So the problem on Dying Light and They are billions resolved, i had no problem playing those but still could not make it into Civ V or Fallout 4.

The problem still persist the same way, so only thing i can do is to reboot PC because neither Ctrl+Alt+Del nor Alt+Tab worked for me since i could not see any display. I also listened closely if my fans are working with in a high pitch, but they were working quite smoothly.

My Desktop Spesifications are;
CPU; Ryzen 5 3600x + Wraith Spire 3.8 - 4.4 GHz 35Mb, 95W 7nm
MBD: Gigabyte x570 Aorus Pro AM4 AMD Ryzen DDR4 4400MHz (O.C.) M.2 RGB
GPU: MSI Radeon RX 5700 XT Gaming X 8GB GDDR6 256bit DX12 AMD Radeon
RAM: Corsair 2x8GB Vengeance DD4 3200Mhz CL16 Dual Kit
SSD: Corsair 240GB Force Series MP510 NVMe M.2 SSD (3100MB Read/ 1050MB Write)
HDD: Seagate Barracuda 3.5'' 1 TB Sata 3.0 64MB Cache 7200Rpm
PSU: Xigmatek Minotaur Full Range 80+ Gold 650W Full Moduler
Case: Thermaltake v200TG 3x120mm RGB Fans MidT ATX Gaming
Display: AOC 27" C27G1 144 Hz 1ms HDMI DP FreeSync / G-Sync Full HD Curved Gaming Display
I also use Window 10 Home (64bit)

I found out a video on youtube and the person says it is related to my PSU, and last time i posted a thread here about my build it was not recommended to buy the PSU i use now, but it was too late because i already ordered it in that time. Now, i just want to be sure what my problem is before making more faulty purchases.
 
....
I found out a video on youtube and the person says it is related to my PSU,
....
While this problem isn't affecting everyone it's common enough and apparently AMD's having troubles duplicating it reliably. So one of the blames is on PSU's for GPU problems, which is not uncommon since they draw so much power.

Turning off browser hardware acceleration does seem to help, based on comments, especially if running a Chomium browser (like the new Chrome based Edge or Chrome browser).

What I found to fix my problems is to do a thoroughly clean install of the latest drivers. That means uninstalling the current drivers, restarting in safe mode with no network support (turn off router if you have to), run the AMD CleanUp utility, then also in safe-mode run Display Driver Uninstaller. Only after that let it restart in normal windows mode, but leave network support turned off.

Now install the latest drivers from AMD, when you do go into advanced install and tick the box to do a reset of settings. This whole process seems to clear out any residual settings or files that may contribute to problems. Probably overkill, but it seems a good idea.

After installing you can turn on network and let Windows do any updates it may feel necessary. Also, run the card without any overclocking or tweaking if you can just to see if it's stable for you.

In the end, while it's not universal there are enough people having problems you may just be one (see that story linked above). AMD is looking into this so you may have to hold on for one or two more driver updates to fix it; at least they do updates pretty regular.
 
Last edited:
Mar 6, 2019
7
0
10
0
Well, i just tinkered with AMD software a little and closed the FreeSync, Radeon Chill, Radeon Boost and Radeon Enhanced Sync, and the problem just went away. i was playing the Civ V for 3 days now without a single problem. I already sent a mail to AMD about it and soon as they make a return i will also explain what i did to them. I dont know about the background of what i did, but still no problem what so ever. Thanks for the lead peeps.
 

ASK THE COMMUNITY

TRENDING THREADS