I get MUCH worse Frames when I Stream...

Dec 20, 2018
10
0
10
0
I get MUCH worse Frames when I Stream..

I primarily play PUBG and while I realize it is not the most optimized game in the world I get on average 120 FPS while not streaming and about 60-70 FPS while streaming. It drops to 30-40 FPS frequently especially when things are happening, like early game drops or when shooting an enemy (Very Frustrating). It also seems to introduce microstutters between frames

PC SPECS:
CPU -> Ryzen 2700x
GPU -> NVIDIA GTX 1060 6gb
RAM ->16gb DDR4 (2x8) Corsair Vengeance LPX 3000 MHz
MOBO -> X470 Aorus Gaming 5 Wifi
PSU -> Corsair TX850
SSD -> M.2 2280 SX6000 (256gb)

I feel like my PC should be able to run the game smoothly and stream at the same time considering the 2700x has 8-cores, and with how smoothly my game runs with the 1060 while not streaming, I don't see how that could be the issue either.

Regardless, will streaming from a second PC help my game run smoother while streaming? Should I get a 1080ti? Does gaming and streaming simultaneously compete for bandwidth no matter what and I should upgrade my internet (I get 160+ Mbps Download and 10-15 Mbps Upload)?

Thanks for your help.
 
Dec 20, 2018
10
0
10
0


16gb DDR4 (2 sticks x 8gb) Corsair Vengeance LPX 3000 MHz in slots 1 and 3
 
Have you gone into BIOS and enabled XMP for your RAM? If you haven't, they'll be running at default speed instead of 3000MHz. Default is likely 2133 or 2400 if I had to guess.

Consult your motherboard manual if you're not sure how to do this.

Please make sure this is done and then try to stream again.
 
Dec 20, 2018
10
0
10
0




It was in fact disabled and defaulted to 2133. I enabled it and will Stream tomorrow again after work, I'll let you know if that changes anything!
 


It does compete for bandwidth no matter what but you can easily test if that's the problem,just record the stream to your HDD instead of really streaming it, if it still reduces your FPS it's not the bandwidth but how the streaming is set up.
 
Dec 20, 2018
10
0
10
0


I noticed it did help with making my frames smoother however first my game crashed, I reloaded, then my Streaming software crashed, I reloaded, then my PC crashed.

I've disabled XMP
 


Sadly, this is common. Ryzen is very picky when it comes to RAM and XMP settings.

Here's what I recommend:
1) Turn on XMP.
2) Write down the settings that XMP applies.
3) Turn XMP off and type in the settings that XMP had applied.
4) Back off on the memory frequency to the next lower standard clock (for example 3000MHz could become 2933MHz).
5) Make sure voltage is set correctly. If you have 1.2V memory, try 1.25V. Even try 1.3V. Be aware that the freaking huge metal plate on that memory will keep it plenty cool as long as you don't pull a stupid and go for 2V or something.
6) Repeat step 3 until the system is stable.
7) Please post back with your results. The more I know about the way your system is behaving, the better I can understand your issue.
 
Dec 20, 2018
10
0
10
0


When XMP is enabled it defaults to 3000 MHz at 1.35V, and I've tried to manually set the Clock speed but it is grayed out and only allows my to choose "Disabled" or "Profile 1" with the above settings
 
Dec 20, 2018
10
0
10
0


Thank you for trying to help I really appreciate it! I'm meeting with a friend in the next couple days as well who might be able to help. I'll keep you updated if anything changes.
 

ASK THE COMMUNITY

TRENDING THREADS