[SOLVED] I get stuttering whenever I play a video with VLC

Shady_7

Reputable
Jul 17, 2017
17
0
4,520
1
Ever since I got my new laptop, playback always stutters once every few minutes or so, in any video whatever the resolution. Never had this problem with my old laptop at all and had it with this one since day one. Tried MPC-HC and videos in the browser work with no problems. Tried the solutions on google like
  1. Changing caching value to 600 then to 1000
  2. Changing skip the loop filter for H.264 decoding
  3. Allowing speed tricks option for FFmpeg settings
  4. Disabling hardware decoding (Then I tried changing it to DirectX Video Acceleration (DXVA) 2.0 but it crashed first time then gave me an audio without video)
  5. Changing the video output module: Tried every one of them, some didn't show subtitles and some gave audio without video but the ones who showed the subs and the video still had stuttering.
  6. Changing threads for FFmpeg to 2.
I restarted VLC after each change in the settings of course but the stuttering was still there.
The stuttering lasts for about 3-6 seconds.
I got the laptop a year ago and when I got this problem I thought it was something with the current VLC build or the graphics drivers so I used MPC-HC instead. But now I waited for a year while updating the drivers and windows regularly as well as VLC and the problem is the same. I don't want to keep using MPC so any help will be appreciated.

VLC 3.0.16 Vetinari
Laptop specs
Processor Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz
Installed RAM 16.0 GB
System type 64-bit operating system, x64-based processor
Graphics
lntel(R) UHD Graphics 630
Driver Version: 27.20.100.8729
NVlDlA GeForce GTX 1660 TI with Max-Q Design
Driver Version: 30.0.14.9613
OS
Edition Windows 10 Pro
Version 21H1
OS build 19043.1288
Experience Windows Feature Experience Pack 120.2212.3920.0
 

jojesa

Illustrious
Thanks for the quick reply.
  • The caching setting I changed is the file caching, for local files, in all settings > Input / Codecs > advanced > first option: File caching (ms). I changed this to 600 then 1000, nothing happened.
Setting the file caching value to 1000 will buffer just 1 second. Try 20000, so it will buffer 20 seconds, and see if that helps.

  • I tried assigning 'high performance" from Graphics settings in windows then "power saving", nothing changed. VLC appears in Nvidia GeForce Experience Nvidia GeForce Experience (even with neither high performance nor power saving assigned for it in Graphics settings) but there's no settings I can change in GeForce Experience.
Changing which app uses a GPU should be done either on Windows Graphics Settings or on the NVIDIA Control Panel.
Windows 10 20H1 and newer versions , overrides any settings made in the NVIDIA Control Panel under Preferred graphics processor setting for that application.

By the way, Nvidia GeForce Experience is known to causes issues on media player apps.

  • It happened with MKV and MP4 formats, those are the two I use the most.
  • I never tried streaming and I only play local content.
  • Yes, I think they stayed the same after changing the caching value. And I believe it happens at random intervals so some times the interval between two stuttering occasions would be 2 minutes and sometimes it would be 20 minutes (even without changing any settings) to the point I would think the problem was solved but then a stuttering happens and another one after a few minutes. I think this also happened when I disabled hardware acceleration, there was a long interval without a stuttering but after the first one, another shortly followed so maybe it just happened randomly.
  • Yes, I tried reinstalling VLC.
Thanks again.
Try disabling Hardware Decoding
Open VLC and navigate to Tools > Preferences.
When you see the settings window, click on Input and Codecs on the left sidebar.
Disable the Hardware-accelerated decoding option.

If nothing works, then get an alternative video player, like GOM Player
 
Reactions: Shady_7

jojesa

Illustrious
There are several caching settings (disk, file, etc. ), which did you changed?
Your laptop has both integrated and dedicated graphic cards, so try assigning one card, then try the other...see if that solves the issue.
Which format (MP4, MKV, WMV, etc.) are you playing ?
Does it happen across all media formats?
Does it happens only when playing streaming media or when playing local content?
If it happen when streaming content, what's the Internet speed?
When caching value was changed to 600 then to 1000 did the stutter intervals remained the same?

Have you tried uninstalling and re-installing VLC?
 

Shady_7

Reputable
Jul 17, 2017
17
0
4,520
1
There are several caching settings (disk, file, etc. ), which did you changed?
Your laptop has both integrated and dedicated graphic cards, so try assigning one card, then try the other...see if that solves the issue.
Which format (MP4, MKV, WMV, etc.) are you playing ?
Does it happen across all media formats?
Does it happens only when playing streaming media or when playing local content?
If it happen when streaming content, what's the Internet speed?
When caching value was changed to 600 then to 1000 did the stutter intervals remained the same?

Have you tried uninstalling and re-installing VLC?
Thanks for the quick reply.
  • The caching setting I changed is the file caching, for local files, in all settings > Input / Codecs > advanced > first option: File caching (ms). I changed this to 600 then 1000, nothing happened.
  • I tried assigning 'high performance" from Graphics settings in windows then "power saving", nothing changed. VLC appears in Nvidia GeForce Experience (even with neither high performance nor power saving assigned for it in Graphics settings) but there's no settings I can change in GeForce Experience.
  • It happened with MKV and MP4 formats, those are the two I use the most.
  • I never tried streaming and I only play local content.
  • Yes, I think they stayed the same after changing the caching value. And I believe it happens at random intervals so some times the interval between two stuttering occasions would be 2 minutes and sometimes it would be 20 minutes (even without changing any settings) to the point I would think the problem was solved but then a stuttering happens and another one after a few minutes. I think this also happened when I disabled hardware acceleration, there was a long interval without a stuttering but after the first one, another shortly followed so maybe it just happened randomly.
  • Yes, I tried reinstalling VLC.
Thanks again.
 
Last edited:

jojesa

Illustrious
Thanks for the quick reply.
  • The caching setting I changed is the file caching, for local files, in all settings > Input / Codecs > advanced > first option: File caching (ms). I changed this to 600 then 1000, nothing happened.
Setting the file caching value to 1000 will buffer just 1 second. Try 20000, so it will buffer 20 seconds, and see if that helps.

  • I tried assigning 'high performance" from Graphics settings in windows then "power saving", nothing changed. VLC appears in Nvidia GeForce Experience Nvidia GeForce Experience (even with neither high performance nor power saving assigned for it in Graphics settings) but there's no settings I can change in GeForce Experience.
Changing which app uses a GPU should be done either on Windows Graphics Settings or on the NVIDIA Control Panel.
Windows 10 20H1 and newer versions , overrides any settings made in the NVIDIA Control Panel under Preferred graphics processor setting for that application.

By the way, Nvidia GeForce Experience is known to causes issues on media player apps.

  • It happened with MKV and MP4 formats, those are the two I use the most.
  • I never tried streaming and I only play local content.
  • Yes, I think they stayed the same after changing the caching value. And I believe it happens at random intervals so some times the interval between two stuttering occasions would be 2 minutes and sometimes it would be 20 minutes (even without changing any settings) to the point I would think the problem was solved but then a stuttering happens and another one after a few minutes. I think this also happened when I disabled hardware acceleration, there was a long interval without a stuttering but after the first one, another shortly followed so maybe it just happened randomly.
  • Yes, I tried reinstalling VLC.
Thanks again.
Try disabling Hardware Decoding
Open VLC and navigate to Tools > Preferences.
When you see the settings window, click on Input and Codecs on the left sidebar.
Disable the Hardware-accelerated decoding option.

If nothing works, then get an alternative video player, like GOM Player
 
Reactions: Shady_7

Shady_7

Reputable
Jul 17, 2017
17
0
4,520
1
Setting the file caching value to 1000 will buffer just 1 second. Try 20000, so it will buffer 20 seconds, and see if that helps.
That solved the problem. Thanks a lot.

Edit: But is there any way to decrease the "side effects" of changing that setting? I feel that fast forwarding and going backwards aren't as smooth as they were and when I do either of them, subtitles may lag and not show the first one.
 
Last edited:

jojesa

Illustrious
That solved the problem. Thanks a lot.

Edit: But is there any way to decrease the "side effects" of changing that setting? I feel that fast forwarding and going backwards aren't as smooth as they were and when I do either of them, subtitles may lag and not show the first one.
Yes, fast forward and rewind beyond the 20 seconds won't be as smooth and that is a known side effect.
If you are having issues will all videos, then it could be how the video are encoded.
Use VLC to convert one of the video files and see if the issue is there after converting it.
 

ASK THE COMMUNITY