Question I got a Crucial M.2 drive and it wont show up in windows, bios, or disk management

Jul 12, 2019
3
0
10
0
I have an asus ROG STRIX x470-F
windows 10
the drive is a Crucial P1 NVMe M.2 500GB SSD
I have a Zotac Gaming Geforce rtx 2060 Dual-Fan 6GB GDDR6 PCIe Video Card (which is in PCIEx16_2 slot)

I had a wireless adapeter in PCIEX1_1, but I moved it to 1_2, because the manual for the MOBO says that occupying 1_1 and 1_3 cause the M.2 slot to be sata only, and when that didnt work I removed it completely, and the M.2 drive still didnt show. I am using the most current bios version (version 5007), i dont know what else to do. please help (if Im missing any important info please feel free to ask)
 
Jul 12, 2019
3
0
10
0
what the cpu?
why is the gpu on the _2 slot?

full system spec?
CPU: AMD Ryzen 7 1700X 3.4 GHz 8 Core AM4
Mobo: ROG STRIX x470-F
RAM: G.Skill Trident Z RGB 16GB (2 x 8GB) DDR4-3200 PC4-25600 CL16 Dual Channel Desktop Memory Kit
GPU: Zotac Gaming Geforce rtx 2060 Dual-Fan 6GB GDDR6 PCIe Video Card (which is in PCIEx16_2 slot)
SSD: samsung SSD 860 EVO 250 GB, Crucial CT525MX300SSD1 500GB
HDD: WD Blue 1TB Desktop Hard Disk Drive - 7200 RPM SATA 6Gb/s 64MB Cache 3.5 Inch, TOSHIBA DT01ACA100 1TB 7200 RPM 32MB Cache SATA 6.0Gb/s 3.5"

The drive not showing up is Crucial P1 NVMe M.2 500GB SSD

the GPU is in the second slot because I have Cooler Master Hyper 212 RGB Black Universal CPU Cooler to cool the CPU and the 1st of the three slots is right up against it.
 

ASK THE COMMUNITY