[SOLVED] I got a new Asus Z87-K Mobo green light but no boot graphics card is lit up red led it's a Rx 580 snow leopard

Joshua Alves

Prominent
Mar 29, 2020
37
0
530
0
This is my configuration
Xeon E3-1246 v3 3.5 GHz cpu
HyperX Fury Savage 8gb x 4 heat spreader red ram DDR3
PSU is a spirit 700 watt PSU black edition
Case Dark Flash Phantom case
RX580 Dual Snow Leopard GPU

I need help just bought this Mobo off of Newegg it's a brand new Mobo refurbished used but new RX580 graphics card lights up red while Mobo is lit up green no boot tho
 
Last edited:
This is my configuration
Xeon V2 1250 3.5 GHz
HyperX Fury Savage 8gb x 4 heat spreader red ram
PSU is a spirit 700 watt PSU black edition
Case Dark Flash Phantom case
RX580 Dual Snow Leopard GPU

I need help just bought this Mobo off of Newegg it's a brand new Mobo refurbished used but new RX580 graphics card lights up red while Mobo is lit up green no boot tho
Can you double check on your cpu model, I am not seeing it for use on that motherboard.
 

DSzymborski

Titan
Moderator
"Brand new refurbished used"

So...uh...it's used? And is the RX 580 actually new or used? Don't see a lot of those new anymore. It's helpful to know what we're working with. Can you verify any of these parts were working before assembling this PC?

You don't happen to have a PSU that's safe to use, do you? It may not be causing this problem, but these components shouldn't be used with a very cheaply made, fake 700W junk PSU. Would kind of defeat the purpose of diagnosing the problem if you remedy this problem and then immediately fry your new GPU with a dodgy power source.
 

DSzymborski

Titan
Moderator
I've had the RX580 Sitting around it's an Asus brand GPU
So you bought it new (not used or refurbished) and you haven't used it yet, and you just finally opened it from the package?

Again, it's helpful to be specific. We're not at your PC. We can not see everything you do, hear everything you do. We can not look at the individual parts nor do we magically know the history of the parts involved. All these things you have to convey to us.
 

DSzymborski

Titan
Moderator
Well I opened the GPU left it sitting around for about a couple of years never touched it until now it's not dirty or anything
That's unfortunate; your warranty started running when you bought it. But if it's less than three years you bought it new, then at least you may have some warranty time left.

Is there any sticker on the motherboard indicating what BIOS version you have?
 

ASK THE COMMUNITY

TRENDING THREADS