Question I had a broken pc, found out the problem and now facing the same system issues

Feb 13, 2021
2
0
10
0
Hey guys so about a month ago, I had an issue where my pc would boot however would not display anything. Initially I thought it was my power supply but my brother said no it shouldn’t be as it is from EVGA. We tested out all the components and we found it was the Cpu and motherboard that was ‘faulty’. After I received my parts, my brother ,after selling the cpu, said that the person he sold it told him that it was working but my pc was working fine so I didn’t mind what he was saying. Fast forward to a week ago my pc started being weird as my pc started to freeze and I would have to restart my pc and such. However a few days ago my pc got it’s first ever BSOD. So I thought ‘oh it’s fine then’ However I was mistaken as after every boot around 30 seconds after logging in every time, my pc would freeze or I would get a BSOD and now today I get the same problems as when I had my old components.

I need help. I’m still thinking that the psu is causing the problem as I’m thinking that it’s damaging my components but my brother thinks that I overheated it as I play games for a large amount of hours (8-12). But I checked one time after gaming that my cpu was 59 degrees.
 
Feb 13, 2021
2
0
10
0
Hey guys so about a month ago, I had an issue where my pc would boot however would not display anything. Initially I thought it was my power supply but my brother said no it shouldn’t be as it is from EVGA. We tested out all the components and we found it was the Cpu and motherboard that was ‘faulty’. After I received my parts, my brother ,after selling the cpu, said that the person he sold it told him that it was working but my pc was working fine so I didn’t mind what he was saying. Fast forward to a week ago my pc started being weird as my pc started to freeze and I would have to restart my pc and such. However a few days ago my pc got it’s first ever BSOD. So I thought ‘oh it’s fine then’ However I was mistaken as after every boot around 30 seconds after logging in every time, my pc would freeze or I would get a BSOD and now today I get the same problems as when I had my old components.

I need help. I’m still thinking that the psu is causing the problem as I’m thinking that it’s damaging my components but my brother thinks that I overheated it as I play games for a large amount of hours (8-12). But I checked one time after gaming that my cpu was 59 degrees.
 

ASK THE COMMUNITY