Question I had to move my SoundBlaster X AE-5 to new port when I installed my new RTX 2080 ti

Jun 27, 2020
2
0
10
0
My computer no longer can detect the Soundblaster card or sees it. I have read i need to put back in old port and uninstall drivers. but that would mean taking out the RTX which i do not want to do. Looking for instruction to get sound card active in new port. Everything else works on my comp except the SB card. Thanks,
 
Jun 27, 2020
2
0
10
0
Just Uninstall the driver and Install it again.
FYI when i moved back to original port card was in.... computer detects and runs fine. When i move it to new port because the GPU covers original port i had it plugged into the computer does not see it.

I just did the uninstall and install of drivers and still get the below.

"Your audio device cannot be detected. please check your connection" Connection is fine. computer just does not see it in new port.
 

gamenadez

Commendable
Feb 17, 2018
378
51
1,790
11
FYI when i moved back to original port card was in.... computer detects and runs fine. When i move it to new port because the GPU covers original port i had it plugged into the computer does not see it.

I just did the uninstall and install of drivers and still get the below.

"Your audio device cannot be detected. please check your connection" Connection is fine. computer just does not see it in new port.
then that pci slot on mobo have problem..or maybe check bios if there pcie config..
 

ASK THE COMMUNITY

TRENDING THREADS