[SOLVED] I have 500mbps on both speedtest.net and other speedtest websites. But i only have 5mbps-15mbps when i download something. Please help!

Status
Not open for further replies.
May 18, 2021
1
0
10
0
This problem occured a few weeks ago and i haven't been able to fix it. I have tried factory resetting my PC, i have tried downloading the latest drivers and uninstalling them, i have tried using 10+ diffrent LAN cables and i have tried using another switch. All other PCs i've tried works fine even if i use the same switch and LAN cables. My internet seems to be working fine, and my network card seems to be working well too. But for some reason all platforms and browsers seem to be downloading at 5-10mbps max. Plus when i download something, my internet plummits (only on my pc). My ping skyrockets to near 80 (from 3) and i get 60 mbps download and around 2 mbps upload. Please help!

most important Specs:
CPU Ryzen 7 3700X
GPU 3070
MOBO MSI B550 MPG GAMING EDGE WIFI
ISP: Altibox (norwegian company)
My router is also from Altibox, but im unaware of router specs

I have a CAT5 LAN cable. It is capable of 1gbps

I use Windows 10

Edit: Internet is 100% fine. My servers show 500 up and 500 down, wich is what I get from ISP. So the problem has something to do with my PC, but only when actually downloading stuff.

You can also read about the problem on this forum https://linustechtips.com/topic/1338992-i-have-500mbps-on-both-speedtestnet-and-other-speedtest-websites-but-i-only-have-5mbps-15mbps-when-i-download-something-please-help/?tab=comments#comment-14741702
More information is in the comments
 
I would normally say it has to be some software since speedtest works fine. Speedtest is just a file download and upload that is not saved. It really is not much different than using a more simple download in the browser.

The thing that stands out is your motherboard has a 2.5g ethernet. There seems to be a lot of issues with these ports. Both intel and realtek brands have lots of people reporting strange issues.

What also makes this hard is the next recommended test to rule out some garbage software is to boot a unix USB image. Problem is you would have to find one that has driver support for the 2.5g port.

Maybe try to boot windows into safe mode and see if it is any different.

I really don't know why they put these ports on machines. 1gbit is fast enough for almost all uses, internet even at 1gbit is not available to a lot of people. If you really need faster 10g ports are only slightly more and use technology that has been around for many years and has few bugs any more.

At some point you might consider buying a 1gbit add in card if you can not get this resolved with software.
 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS