I have a 500Mbps connection, a router that supports up to 1Gbps connection, and a CAT5e cable, but why I'm still getting 100Mb

Feb 24, 2018
2
0
10
0
My ISP just upgraded my 100Mbps connection to 500Mbps. They also upgraded my router from TP-Link Archer C20 (supports only 100Mbps) to TP-Link Archer C1200 (supports up to 1Gbps). My desktop is on wired connection via a 30m CAT5e cable. However, when I do speed test, I'm only getting 100mbps connection. Windows' network connection status is also showing only 100mbps. Noted that, my desktop is using Asrock H370M Pro 4 motherboard which should support Gigabit LAN. At first I thought the ISP haven't upgraded my speed but when I run the speed test on my phone (which connected to 5GHz wifi), I'm getting more than 300 Mbps.

Any idea why this happened? Is my CAT5e cable faulty?
 
If the PC says it is running at 100mbps it is highly likely you have a bad cable. Cables are really strange when they go bad they can work on some machines but not others. You should also check the nic setting to be sure it is set to auto and not hard coded to 100mbps. The default setting is auto so you would have to have changed it but maybe some program changed it.
 

justajok3

Commendable
Dec 16, 2016
22
0
1,510
0


I have similar problem with you, but I am sure that my ethernet cable is not faulty because I tried it on my laptop can it can get 500mbps but when it connected to the desktop it can only get 100mbps

 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS