[SOLVED] I have a local PSU in my system, Can it cause Wifi adapter to be under powered or any issues

rajuplays

Prominent
Nov 11, 2018
39
1
535
0
I installed SSD and new windows yesterday but my WiFi(using via wifi adapter) on the PC although staying connected sometimes stops the internet.
Secondly to check if the internet or router is issue, when the PC is showing disconnected, Phone and chromebook internet works fine and also show better speed test than my PC.
wifi adapter is also from tplink
Router is tp link wifi wr841n

I did a dumb mistake of not asking the internet guy to install the router with Ethernet cable for pc as i had the adapter.

I have been using the psu since a year or two but earlier i dint have the internet or trasnfer issues of wifi. Does ssd takes a lot of power? ssd is installed in m.2 slot nvme.
or else the issue is with the drivers of wifi but the device is simply plug and play.
 
install the latest driver for you wifi device

the nvme SSD doesn´t need much power, the PSU shouldn´t be a problem

did you try a different USB port?

Did you change the position of the PC after the upgrade?

did you reinstall windows after the upgrade?
 
install the latest driver for you wifi device

the nvme SSD doesn´t need much power, the PSU shouldn´t be a problem

did you try a different USB port?

Did you change the position of the PC after the upgrade?

did you reinstall windows after the upgrade?
 

rajuplays

Prominent
Nov 11, 2018
39
1
535
0
Yeah i used a old windows before, not its the latest one.
Ohh yeah just found the cd drive for the wifi adapter. I will install drivers and update here if it goes well.

right now when i check the device in the device manager its shows that it uses realtek drivers, should i have uninstalled those before running the setup>?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS