Question I have a really low igpu temp on my ryzen 5 4650g

Oct 24, 2021
9
0
10
0
Hello

I have noticed that the igpu on my ryzen 5 4650g is reporting temperatures of 35 to 42°c while gaming in games like halo infinite, bf2042, warzone, genshin impact, etc. I found this weird because 2 weeks ago the temps used to be 65 to 75°c while playing this games and now its showing this really low temps, the average ambient temp in my house is around 24°c and theres no winter where i live.
Is this normal or there is a problem with my hardware that now is reporting the temps like that.
let me know because im worried that the cpu will be damage if the temps increse but the cooler and the fans dont ramp up because the reported temp is not the correct.

my set up
cpu: ryzen 5 4650g
cooler: ABKONCORE RGB CPU Cooler CT404B
mb:gigabyte b450 aorus elite v1 bios f62c
psu: corsair vs650w 80 Plus White
ram: crucial ballistix 8x2 3600
drives: wd sn550 500g 60%
crucial mx500 500g 40%
 

LinuxDevice

Honorable
May 20, 2017
538
45
11,440
101
Run the task manager and look at %CPU and %GPU usage. Perhaps the iGPU just isn't being fed enough data to care. Maybe check frame rates and see if those are "typical" versus what you had in the past.

EDIT: I forgot to mention, my CPU is a bit slow, but my GPU is quite fast. As a result, even when running max frame rates on large games my GPU never exceeds 40% use and peeks at about 66 degrees C. When working with "easy" tasks it hovers around 40 C. You can't really judge temperature unless you know what the current work load is.
 
Reactions: SVF94
Oct 24, 2021
9
0
10
0
Run the task manager and look at %CPU and %GPU usage. Perhaps the iGPU just isn't being fed enough data to care. Maybe check frame rates and see if those are "typical" versus what you had in the past.

EDIT: I forgot to mention, my CPU is a bit slow, but my GPU is quite fast. As a result, even when running max frame rates on large games my GPU never exceeds 40% use and peeks at about 66 degrees C. When working with "easy" tasks it hovers around 40 C. You can't really judge temperature unless you know what the current work load is.
Hi

The GPUusage is 100% and CPUis around 50-70%, the fps are the same as always, nothing is different, i didnt feel anything extrange or weird in the computer, i havent done or change anything.
the only thing thats differente is the temperature of the igpu
 

LinuxDevice

Honorable
May 20, 2017
538
45
11,440
101
Since this is an iGPU it tends to say the temperature measurements for the package containing the iGPU (the CPU) is where the heat would probably go (I'm doing a lot of guessing here). The CPU itself seems well-suited to feed the iGPU to its max. I'm wondering if maybe there is another discrete GPU, in which case this might be measuring its temperature instead. If not, then perhaps an update is causing temperature to be read differently. Not sure, but obviously if the iGPU is itself at 100%, then temperature would have gone up (but when integrated in the same package as the CPU, who knows?). Does the CPU itself show an increase in temperature?
 
Oct 24, 2021
9
0
10
0
Since this is an iGPU it tends to say the temperature measurements for the package containing the iGPU (the CPU) is where the heat would probably go (I'm doing a lot of guessing here). The CPU itself seems well-suited to feed the iGPU to its max. I'm wondering if maybe there is another discrete GPU, in which case this might be measuring its temperature instead. If not, then perhaps an update is causing temperature to be read differently. Not sure, but obviously if the iGPU is itself at 100%, then temperature would have gone up (but when integrated in the same package as the CPU, who knows?). Does the CPU itself show an increase in temperature?
i dont have a discrete GPU, the only thing i use is the igpu and the CPU shows50°c while gaming on the radeon software.
prior to me noticing this low temp i got 2 updates, one for windows and the other one for GPU driver, so maybe one or both of the updates cause the temp to be read wrong.
i tried a fresh install of windows but nothing change.
 
Last edited:

LinuxDevice

Honorable
May 20, 2017
538
45
11,440
101
This is likely a software issue since it seems that graphics are fully functional and not misbehaving. You don't really need to worry about low temperatures, though it does make it suspicious that the measured temperature is not valid. Not sure what to advise on this since likely everything is working fine and only the measurement is wrong.
 

ASK THE COMMUNITY