Question I have Gigabit connection but ethernet is capping my speed at 59Mbps.

reaLab

Reputable
Aug 7, 2015
4
0
4,510
0
So basically, when connecting using wired ethernet, my internet speed is capping at 59Mbps and it never go above 60Mbps (using speedtest.net, fast,com, xfinity, spectrum). I also tried to check the speed on safe mode and using a live Linux and the result is still the same.

Network and Internet Settings> Change adapter options> Ethernet > Status detects the speed at 1.0Gbps.

But when using a Wifi usb adapter, my internet speed is back to normal at 300Mbps. Even my other wireless devices connects at 300Mbps.

Before anyone suggest that it may be the cable, no it is not, because I was having a normal connection speed for the past few months and this problem just happened recently without even touching the cables.

I remember this problem occurring after I tried the ipconfig/release and renew, and tried to set a static IP. That's probably the only thing I tampered with which caused this problem. I have never touched the ethernet cables because it's inside the walls nor touched the router itself.

Any suggestion would be much appreciated.

Hardware used:
Netgear Router/Modem combo
Asus X470 F motherboard
TPLink Switch Hub rated at 1Gb
 
Really puzzling! The live cd tells me that it's a hardware issue, but it still doesn't seem like hardware would fail after just trying to set a static IP.

Do you have another wired nic that you can connect to the computer and test? I have a funny feeling that somehow it's the mac address on the wired nic that's somehow limited in the netgear now somehow as speeds are fine on the wifi mac. Another mac address on the same computer would help confirm that hypothesis.
 

ASK THE COMMUNITY

TRENDING THREADS