Question I have no video output please help

Feb 12, 2019
6
0
10
0
My system specs are: ryzen 5 1600, asus b350 motherboard, 16gb of Corsair ram, 700w psu, and my new titan x. I’ve been trying to get this thing to work because I bought it from a friend who had it working prior use and he sold it to me but in my system I can’t seem to get and output. My old gpu the gtx 1060 3gb works fine when I switch them out to see if maybe my monitor could be the problem the video comes back with the gtx 1060. I don’t know how to get the drivers on the titan because I can see any output to do anything. The titan x lights up after a second or two goes dark and lights up again a few seconds after. On screen everything is blank but for a second I can see windows but it goes blank again. I’ve made sure all power connectors work and everything is in the right spot.
 
Feb 12, 2019
6
0
10
0
Somewhere between 650-750W should be fine. I think 650W should be good enough.

650W - https://pcpartpicker.com/product/WrNypg/seasonic-focus-plus-gold-650w-80-gold-certified-fully-modular-atx-power-supply-ssr-650fx

But before switching out the PSU, what troubleshooting steps have you gone through?
I’ve tried uninstalling the drivers and re installing them while my titan was connected at the same time as my 1060, I’ve checked for loose wires, I’ve cleared cmos, I’ve used all 3 psi-e slots on my motherboard and tried the different output cables on the card and still nothing
 
Feb 12, 2019
6
0
10
0
Somewhere between 650-750W should be fine. I think 650W should be good enough.

650W - https://pcpartpicker.com/product/WrNypg/seasonic-focus-plus-gold-650w-80-gold-certified-fully-modular-atx-power-supply-ssr-650fx

But before switching out the PSU, what troubleshooting steps have you gone through?
I went out and got a 1000w psu for sale and still nothing as well but the same thing happens the screen shows it’s on with the lighter dark colour and flashes the asus logo for a split second.
 

Similar threads


ASK THE COMMUNITY