Question I have some weird problem

Jul 20, 2019
3
0
10
0
Hello ,

so i got new setup some weeks ago.

GTX 2070
i7 8700
16G RAM

Im playing a small game and when i installed it first time i felt something is not right its still moving in frames even with a new PC. So i installed fraps i saw i had only 50-70 fps with low graphic options. Then i tested my GPU usage and temp all were good. Same problem in windows or fullscreen mode. Then a bit later i was watching some clips on youtube and ive notice my fps was 180-190 and when i closed it it went back to 60-70 fps.

I decide to install another old game Path of exile and from start i had 400-500 fps but gpu usage was at 90% and temp was super high , i started looking at setting and ive notice it was "fullscreen windowed" and i changed it to fullscreen and everything went to low values.

I reinstalled the windows once. I disable some things in win 10 like game bar and dvr game nothing changed.
 
Jul 14, 2019
72
8
45
1
Have you recently updated graphics drivers? I have seen a new driver version cause odd FPS issues. I hope you're not running any kind of BETA drivers. Also, are you having these FPS/heat issues in all programs/games or just one or two?
 
Jul 20, 2019
3
0
10
0
So first time when i installed win 10 i forgot about drivers and it took some old ones. After some days i downloaded the latest version on a stick and reinstalled the windows without internet (full format etc/clean drive). Nope no heat issue except the one i said above when it started warming up in "fullscreen windowed".
 
Last edited:
Jul 14, 2019
72
8
45
1
Im playing a small game and when i installed it first time i felt something is not right its still moving in frames even with a new PC. So i installed fraps i saw i had only 50-70 fps with low graphic options. Then i tested my GPU usage and temp all were good. Same problem in windows or fullscreen mode. Then a bit later i was watching some clips on youtube and ive notice my fps was 180-190 and when i closed it it went back to 60-70 fps.

I decide to install another old game Path of exile and from start i had 400-500 fps but gpu usage was at 90% and temp was super high , i started looking at setting and ive notice it was "fullscreen windowed" and i changed it to fullscreen and everything went to low values.

I reinstalled the windows once. I disable some things in win 10 like game bar and dvr game nothing changed.
It could very well be a lack of continued support for the game you're playing from the developers. It wouldn't be the first time I saw a dated game run much worse than it should, especially considering the hardware. To test this, have you tried a free GPU benchmark program like Unigine? (I would turn Fraps off for this since it gauges your FPS anyway)
https://unigine.com/en/products/benchmarks (I personally use the superposition version)
This program allows you to put your hardware to the test under a myriad of variables that you can choose yourself in a modern setting. Then, if I recall correctly, you can compare your results with other people with similar hardware to see if it's matching up.

If this benchmark goes okay, then that would suggest that your drivers and hardware etc are fine and it's more an issue with new hardware/drivers trying to run old software which is why some older games come with Microsoft Redistributes.
(this can especially be a problem for games because DirectX keeps being changed and updated for newer stuff).
Otherwise you can try running the game in a compatibility mode but that's not a reliable fix for performance issues.

I would try running a couple GPU benchmark tests to see how it plays out.
 

ASK THE COMMUNITY

TRENDING THREADS