Question I have stable lower FPS (on most details settings) then I should have

May 7, 2019
2
0
10
0
Hello! I am a little bit confused by my almost new GPU (I have the GPU for like 3 months now) and I have a problem with FPS. Since the games I am playing are running mostly on 70fps (and I was used to it because my old GPU) I wasn't really thinking that it's a problem but a few weeks ago I saw few videos on youtube where people playing those games with my GPU on a LOT higher settings.

My PC contains:
GPU: RX 580 8GB Gigabyte Gaming
CPU: FX 6300
Ram: 8 GB (DDR3 1600Mhz, 2x 4GB)

And I am running games like Rainbow Six Siege on 40-80fps on almost every preset (doesn't matter if I play on High or Low, the change is like 2 - 3fps and no I am not playing with V-sync). Those problems are also on other games, for example League of Legends, playing on 70 - 100fps on low/medium/high settings...


Also, I did a benchmark on the Unigine Heaven Benchmark and this was my results:

FPS: 23.6
Score: 596
Min FPS: 7.0
Max FPS: 45.0

Settings:
Render: Direct3D11
Mode: 1920x1080 (4xAA fullscreen)
Quality: High
Tessellation: Normal

I can also provide the whole .html file from this render if needed

Thank you for any tips/advice!
 
May 7, 2019
2
0
10
0
Last edited:
May 10, 2019
38
11
35
0
Sound like a driver problem. Did you uninstall and delete amd graphic drivers? If it comes back which shouldnt as the basic windows driver should load if u uninstalled amds graphics correctly. Anyway if it does go into your device manager find your graphics driver in the list right click it and press delete driver or uninstall driver. Make sure to check that DELETE DRIVERS FROM PC box or else it will reuse them when you restart. After you did delete them you need to restart your pc first. After that install the drivers that work. Report faulty drivers to your oem supplier or even amd itself depending which ones fail on you. Restart pc. Dont forget to re-apply settings to your card as its a total new driver now. See if it stays on thd older working driver by testing again. Oh and make sure no automatic updates is on or anything for your gfx driver. Goodluck
 

ASK THE COMMUNITY

TRENDING THREADS