Question I need an alternative to "Enhanced Multi Core Performance" to get my polling rate stable ?

Mar 29, 2022
5
0
10
0
I have aorus z390 with 9900k.
The problem is, my mouse polling rate looks like this.
View: https://imgur.com/a/SNs8ILY



No matter what i do (disable EIST, SPEEDSTEP, C-states, set constant VCORE, set my cpu to 4.7 GHZ, disable turbo boost, enable turbo boost) the problem does not go away. It results in a dramatic accuracy decrease and a feel of a floating mouse.

But when i set the Enhaced Multi Core perfomance option ON - polling rate becomes perfectly stable and my aim becomes normal. Its not a placebo effect, i get instant 10% (from 50 to 60) accuracy difference in kovaaks in fast tracking scenarios for example. My problem with this option is that my cpu locks at 5 GHZ and temperature becomes too hot. I dont want my cpu burning in idle, so i need an alternative.

My theory about this setting is that it syncs all the cores and because of that my mouse polling rate becomes stable. But i might be wrong, so please, if you know how it works and what should i do manually to achieve the same effect on my polling rate without burning my cpu give me a tip.
 
What mouse do you use?
Have you searched google for issues with that specific mouse?
Have you tried a different mouse?
This sounds like a driver issue to me, the driver thread gets juggled around all the cores changing the latency every time it happens while when all cores run the same the latency stays the same.
If the driver shows up in task manager you can set an affinity for it to only run on one core and you can set priority for it to real-time.
 
Mar 29, 2022
5
0
10
0
What mouse do you use?
Have you searched google for issues with that specific mouse?
Have you tried a different mouse?
This sounds like a driver issue to me, the driver thread gets juggled around all the cores changing the latency every time it happens while when all cores run the same the latency stays the same.
If the driver shows up in task manager you can set an affinity for it to only run on one core and you can set priority for it to real-time.
I have a gpro (wired), FK2, viper mini and MZ1. On all of them i have the same issue.
 

uWebb429

Respectable
May 22, 2020
513
150
2,440
97
I dont want my cpu burning in idle
I run my Intel 10 core CPU at 5000 MHz all of the time and it is not burning hot when idle.



If you want lower idle temps, make sure there is not a bunch of useless crap running in the background. Open the Task Manger, go to the Details tab and organize the running tasks by CPU usage. Get rid of what you do not need.

Try enabling the low power core C7 C state in the BIOS. This reduces power consumption. No need to slow the CPU down. I use the Windows High Performance or Ultimate Performance power plan to run all cores at full speed all of the time.

If running all cores at 5000 MHz creates too much heat then try running at 4900 MHz or 4800 MHz. Set all of the turbo ratios to whatever speed you want to run at. I use ThrottleStop so I can adjust the CPU speed to whatever I like while in Windows. Most users prefer to set the turbo ratios in the BIOS.

MCE sets all of the turbo ratios to the same value. You can do this manually in the BIOS or by using ThrottleStop.



SpeedStep and EIST are two different names for the same thing. It is OK to leave SpeedStep enabled. The Windows power plan is what controls the idle CPU speed. The Windows Balanced power plan is what causes the CPU MHz and voltage to jump up and down when idle.

Intel CPUs use turbo boost to reach maximum speed. Leave turbo boost enabled.
 
Mar 29, 2022
5
0
10
0
I run my Intel 10 core CPU at 5000 MHz all of the time and it is not burning hot when idle.



If you want lower idle temps, make sure there is not a bunch of useless crap running in the background. Open the Task Manger, go to the Details tab and organize the running tasks by CPU usage. Get rid of what you do not need.

Try enabling the low power core C7 C state in the BIOS. This reduces power consumption. No need to slow the CPU down. I use the Windows High Performance or Ultimate Performance power plan to run all cores at full speed all of the time.

If running all cores at 5000 MHz creates too much heat then try running at 4900 MHz or 4800 MHz. Set all of the turbo ratios to whatever speed you want to run at. I use ThrottleStop so I can adjust the CPU speed to whatever I like while in Windows. Most users prefer to set the turbo ratios in the BIOS.

MCE sets all of the turbo ratios to the same value. You can do this manually in the BIOS or by using ThrottleStop.



SpeedStep and EIST are two different names for the same thing. It is OK to leave SpeedStep enabled. The Windows power plan is what controls the idle CPU speed. The Windows Balanced power plan is what causes the CPU MHz and voltage to jump up and down when idle.

Intel CPUs use turbo boost to reach maximum speed. Leave turbo boost enabled.
I went into BIOS and synced my cores by disabling active turbo ratios, but nothing changed, i get stable mouse graphs only when i run MCE on. The problem with MCE that right now, for example, in complete idle it gives my cpu ~1.3 VCORE and it goes as high as 1.35 when gaming. And all that only at 4.8 frequency. Is this even normal? Because it feels like it is not really safe.
 
Mar 29, 2022
5
0
10
0
I honestly dont even have a clue what that MCE does to make my mouse graphs stable, but it still somehow does. Loadline calibration change also made no difference, tried normal, medium, turbo, at 4.5 and 4.7 with manual or auto VCORE and still got the same bad graph.
 

ASK THE COMMUNITY