Question I need Help! PLEASE

May 22, 2020
10
0
10
0
I recently upgraded my GTX 1070 to a RTX 2080 TI and i mainly play fortnite but i cant even get 240FPS and the game stutters i have a Ryzen 9 3950x and my pc is not running like its supposed to , all my drivers are up to date too, i have 32 GB RAM DDR4 3200, PSU is a Corsair RM 750X , 500GB SSD, 2 TB HDD, Water cooling. and for some reason when im in a game my GPU usage is from 40-60% and its not running like its supposed to , plase help me
 
May 22, 2020
10
0
10
0
Did you wipe the drivers of your old gpu before putting your new one in?
Yes I didn’t know about it until a couple days ago and I also did it again today just to make sure but it’s still not working , it’s actually performing the same as my 1070 😕
 

sgnz

Prominent
Apr 19, 2019
50
0
540
1
Okay those temps are good! Do you encounter these issues in any other games? It may just be an issue with the game itself! Have you played around with the settings in fortnite to see if anything changes?
 
May 22, 2020
10
0
10
0
Okay those temps are good! Do you encounter these issues in any other games? It may just be an issue with the game itself! Have you played around with the settings in fortnite to see if anything changes?
In other games it runs a little better but I feel like it should be better , and I play on all low settings on fortnite
 

sgnz

Prominent
Apr 19, 2019
50
0
540
1
When you say run a little better does that mean run fine just not the fps you think you should get? Or do you have stuttering/frame drops? Is your gpu usage in other games close to 100%
 
May 22, 2020
10
0
10
0
When you say run a little better does that mean run fine just not the fps you think you should get? Or do you have stuttering/frame drops? Is your gpu usage in other games close to 100%
Not close to 100% but like 20/30% more than Fortnite and for FPS it’s kinda stable but there’s some games where there’s no difference between this 2080ti and my old 1070
 

sgnz

Prominent
Apr 19, 2019
50
0
540
1
Hmmm. Do you have any 3rd party gpu utilities? Uninstall them they could be the issue

If you have geforce experience uninstall that too.

I manually download my gpu drivers from nvidias website then install them for reference
 

ASK THE COMMUNITY

TRENDING THREADS