I need help with issues concerning my PC! HELP!

devonkjesse

Commendable
Jun 9, 2018
43
0
1,530
0
PSU: EVGA Supernova G2 750W
GPU: MSI GTX 1080 Armor 8GB OC
CPU: Intel i7-7700k
CPU Cooler: Kraken x62
Motherboard: Z270-A Pro
Ram: Corsair Vengence 16GB (2x8GB)
Case: NZXT S340 Elite
SSD: Samsung 860 EVO 2.5" SATA III 250GB Internal SSD
HDD: Seagate BarraCuda 2TB 3.5-Inch SATA 6 Gb/s Internal Hard Drive (ST2000DM006)


Issues:
CPU has somewhat inconsistent usage
CPU has an inconsistent temperature even after I reapplied thermal paste
GPU Usage spikes and drops a lot


(Could ram be the culprit to the issues listed above?)

PSU made a Grinding sound once on startup
PSU makes a faint "himmmmmmm" sound all the time when the fan is going
PSU sometimes sounds like its making a static sound

I have had these issues for a while and I really need help figuring them out!


When I play Overwatch my CPU and GPU usage are low on the menu and only the GPU usage goes up when im in game. The CPU usage stays at a 18%-28%, while my GPU usage goes from a 60%-73% even sometimes to an 81%. This happened out of literally know where considering they use to both say at a solid, consistent 40%-45% almost all of the time whenever I played any game.

I only built this computer with a friend of mine last year in December.


If anyone could help I would honestly be so so so grateful.

If i need to set any setting to fix any of these issues, i will but i'm not comfortable doing what without guidance,


 
Are you having any performance issues, like frame drops, stutters, tearing, low FPS, etc? If no, then nothing is out of place here, CPU usage tends to move around a lot due to background tasks, and GPU usage goes up only when something graphically demanding is running, such as an Overwatch match, and the usage goes down when there's not much going on on the screen, like in the Overwatch menu. The PSU issues might be something to check out further, but there doesn't seem to be much wrong with the CPU and GPU. How much does your CPU temperature vary and what application are you using to measure it?

Edit: What does concern me is how much your GPU usage is. Have you overclocked the CPU? Because Overwatch should be able to utilize 100% of your GPU with an overclocked 7700K. Have you turned VSync on, or any other FPS limiter?
 

devonkjesse

Commendable
Jun 9, 2018
43
0
1,530
0
Thank you for the quick reply

I am having stutters and FPS drop yes
I use V-Sync since my monitor tears a lot

My CPU temps go on a "Sort of cycle" i guess
When in overwatch, they go from 41c-45c back down to 39C and so on

After running firestrike, here are my results if they help: https://www.3dmark.com/3dm/30200174

I have never OC'ed my PC or any part of it ever. I have a 60 FPS limiter on in game + my V-Sync
I Use Cam and MSI Afterburner for my monitoring of temps and usage.
 
Results show in General Tab that memory is running at 2133MHZ which is slow for 7700K.
It appears you don't list Ram Part#, And or Link. Perhaps you don't set memory parameters in BIOS and just leave everything on [Auto]. Perhaps it is your choice of memory which is only vaguely described.
 

devonkjesse

Commendable
Jun 9, 2018
43
0
1,530
0
Thanks for the reply

Im worried i don't know what you mean exactly Calvin, could you explain it for me plz?
What information do you need that i have not provided yet?
 

devonkjesse

Commendable
Jun 9, 2018
43
0
1,530
0
I fixed the Temp issue with my CPU and reinstalled and got my GPU drivers to work as intended. All I need to really fix now is the fluctuating Usage for the GPU and CPU which, and correct me if I'm wrong, could be RAM related as Calvin said?
 


Basically, your RAM speed is slower than is ideal for the 7700K, and this might be because you left the RAM settings in the BIOS to the default. Try using an XMP profile to overclock your RAM, or manually set a higher speed. This may or may not fix the usage fluctuations, only trying it out will tell.
 

ASK THE COMMUNITY