Question i put an upgraded gpu into a prebuilt pc and games have been stuttering sometimes severely

cindyy20

Prominent
May 31, 2018
4
0
510
0
so i have a prebuilt pc (xps 8900) that used to have a gt 730 in it but a couple months ago i replaced it with a 1050 ti (evga ftw 4gb). ever since, i have had bad stuttering on multiple games. i do overclock the gpu and while gaming temps of everything are normal. ive updated all my drivers.
is there a bottleneck or something
os: windows 10
cpu: i7 6700 @3.40Ghz
ram: 8 gb (two 4 gb sticks)
motherboard: dell inc. 0XJ8C4
storage: 1tb toshiba DT01ACA100 (SATA)
psu: stock 460 watt
 
Even though they're both Nvidia cards, I'd

  1. Download the latest driver from Nvidia but DO NOT install yet.
  2. Download and run Display Driver Uninstaller to completely remove the old drivers
  3. Install the drivers that you downloaded in step 1
Also, I would NOT overclock yet. Make sure everything runs well first before doing any overclocking.

If the problems keep happening, it might depend on the games, how high yoursettings are, etc. possibly RAM (some games need more than 8GB), etc.
 

cindyy20

Prominent
May 31, 2018
4
0
510
0
Even though they're both Nvidia cards, I'd

  1. Download the latest driver from Nvidia but DO NOT install yet.
  2. Download and run Display Driver Uninstaller to completely remove the old drivers
  3. Install the drivers that you downloaded in step 1
Also, I would NOT overclock yet. Make sure everything runs well first before doing any overclocking.

If the problems keep happening, it might depend on the games, how high yoursettings are, etc. possibly RAM (some games need more than 8GB), etc.
yes ive done that but thank you
 

ASK THE COMMUNITY

TRENDING THREADS