[SOLVED] I think a "game" is preventing my CPU from running at its max speed

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
I recently noticed my overclocked 10900k was running at 4.9GHz, it's factory speed. After doing some investigating and troubleshooting it seems that the client for League of Legends is what's causing the issue. If I reset my PC it will run at 5.1GHz so long as I don't open the LoL client. If I do open it, then close it, my CPU will only run at 4.9GHz UNLESS I reopen the LoL client. If I reopen it, it will run at 5.1GHz as long as the client is open.

I really can't seem to understand why this would be the case, but I've tested every program and game I typically use, and I can go for weeks without its speed being reduced, but the moment I open, then close the LoL client, it will not exceed 4.9Ghz. I meticulously watch temperatures and voltages, and I've ruled those out as a possibility. It uses the same applied voltage from the overclock even when the speed gets reduced to 4.9GHz. The temps pretty much never reach the 80s except when using something like Cinebench.

Any help with this would be appreciated, thank you.

Relevant Specs:

-Windows 11

-Intel i9-10900k

-NZXT C850(w) PSU

- MSI z490 Unify Motherboard
 

uWebb429

Estimable
@Savage One

Are you running MSI Control Center or any similar CPU control software? If so, uninstall it.

Try running ThrottleStop when your CPU is stuck at 4.9 GHz.

Run the built in TS Bench test and set this to 8 Threads to load your CPU. Post some screenshots of the main ThrottleStop window while the CPU is loaded and this test is in progress. Also post screenshots of the FIVR and TPL windows.

It is possible that your turbo ratios are being set to default values by the LoL client.

Disable all of the virtualization settings including Core Isolation Memory Integrity in Windows 11. When virtualization is enabled, monitoring software might not be able to report your CPU speed correctly.

 

uWebb429

Estimable
@Savage One

Are you running MSI Control Center or any similar CPU control software? If so, uninstall it.

Try running ThrottleStop when your CPU is stuck at 4.9 GHz.

Run the built in TS Bench test and set this to 8 Threads to load your CPU. Post some screenshots of the main ThrottleStop window while the CPU is loaded and this test is in progress. Also post screenshots of the FIVR and TPL windows.

It is possible that your turbo ratios are being set to default values by the LoL client.

Disable all of the virtualization settings including Core Isolation Memory Integrity in Windows 11. When virtualization is enabled, monitoring software might not be able to report your CPU speed correctly.

 

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
@Savage One

Are you running MSI Control Center or any similar CPU control software? If so, uninstall it.

Try running ThrottleStop when your CPU is stuck at 4.9 GHz.

Run the built in TS Bench test and set this to 8 Threads to load your CPU. Post some screenshots of the main ThrottleStop window while the CPU is loaded and this test is in progress. Also post screenshots of the FIVR and TPL windows.

It is possible that your turbo ratios are being set to default values by the LoL client.

Disable all of the virtualization settings including Core Isolation Memory Integrity in Windows 11. When virtualization is enabled, monitoring software might not be able to report your CPU speed correctly.

Okay I ran ThrottleStop twice, first screenshot is during run 1, second is during run 2, third is after run 2.

https://gyazo.com/78324666c3eb3d23f4296c67d9487ac3

https://gyazo.com/c339e26bf0e1272b189f58d6470c2864

https://gyazo.com/b7f1b35f9b58f6876392e36320ed232a


FIVR: https://gyazo.com/7850f9aab0f27bb60a632251b8f35c4f

TPL: https://gyazo.com/aa42f5147566b3fc788a73ec7c44faae


No, I am not running anything that would control my core speeds as I overclocked in BIOS, no MSI Command Center, or even Intel XTU.


I also have no VBS enabled, not even core isolation memory.

Hope this was what you needed, thanks!
 

uWebb429

Estimable
Hope this was what you needed,
This is exactly what I need.



The datasheet for Intel's 10th Gen 10 core CPUs shows at default settings, the recommended PL1 power limit should be set to 125 Watts and PL2 should be set to 250W. Your ThrottleStop TPL screenshot shows that both PL1 and PL2 are set to 125W. That will cause severe power limit throttling during any full load stress test. Cinebench will chug along instead of running at full speed.

Do you want maximum performance or do you want to follow the Intel specs? The recommended specs are just that, a recommendation. Set PL1 to 125W and set PL2 to 250W if you want to follow the Intel guidance.

For maximum performance, I would set PL1 and PL2 to 250W or higher. Some motherboards set these limits to 4095W so a person never has to worry about these limits interfering with maximum performance. I have a similar 10850K and I have both of these power limits set to 300W.

If you want to do some testing, open the TPL window and watch what power limits your CPU is set to before, during and after you open the LoL client. Software is not supposed to be changing these limits but anything is possible.

In the FIVR window the Turbo Ratios or Turbo Groups as Intel likes to call them are set to default values so the CPU will use the 53 multiplier when lightly loaded and this will drop to 49 when all cores are active during a Cinebench run. It will go under 49 unless you increase the turbo power limits. It is possible that the LoL client is changing the Turbo Group values.



If you make any changes in the BIOS, you will need to delete the ThrottleStop.INI configuration file before starting ThrottleStop so it reads any changes you have made from the CPU and does not try and use the previous settings.

The Ratios in the Turbo Groups are supposed to always be decreasing from top to bottom. It sure looks like something has written over top of the original values that you set in the BIOS. This is why your CPU is limited to the 49 multiplier.

I prefer using Adaptive voltage when using different turbo ratios. 1.30V might not be 100% stable when the CPU is lightly loaded and it is using the 53 multiplier. Adaptive voltage adjusts for this automatically. Watch what HWiNFO reports for VCore voltage when testing.

Are you using the Windows Balanced power plan or the High Performance power plan? If you want to save power I would enable the core C states in the BIOS. No need to slow the CPU down to save power as long as the C states are enabled.
 
Last edited:

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
This is exactly what I need.



The datasheet for Intel's 10th Gen 10 core CPUs shows at default settings, the recommended PL1 power limit should be set to 125 Watts and PL2 should be set to 250W. Your ThrottleStop TPL screenshot shows that both PL1 and PL2 are set to 125W. That will cause severe power limit throttling during any full load stress test. Cinebench will chug along instead of running at full speed.

Do you want maximum performance or do you want to follow the Intel specs? The recommended specs are just that, a recommendation. Set PL1 to 125W and set PL2 to 250W if you want to follow the Intel guidance.

For maximum performance, I would set PL1 and PL2 to 250W or higher. Some motherboards set these limits to 4095W so a person never has to worry about these limits interfering with maximum performance. I have a similar 10850K and I have both of these power limits set to 300W.

If you want to do some testing, open the TPL window and watch what power limits your CPU is set to before, during and after you open the LoL client. Software is not supposed to be changing these limits but anything is possible.

In the FIVR window the Turbo Ratios or Turbo Groups as Intel likes to call them are set to default values so the CPU will use the 53 multiplier when lightly loaded and this will drop to 49 when all cores are active during a Cinebench run. It will go under 49 unless you increase the turbo power limits. It is possible that the LoL client is changing the Turbo Group values.



If you make any changes in the BIOS, you will need to delete the ThrottleStop.INI configuration file before starting ThrottleStop so it reads any changes you have made from the CPU and does not try and use the previous settings.

The Ratios in the Turbo Groups are supposed to always be decreasing from top to bottom. It sure looks like something has written over top of the original values that you set in the BIOS. This is why your CPU is limited to the 49 multiplier.

I prefer using Adaptive voltage when using different turbo ratios. 1.30V might not be 100% stable when the CPU is lightly loaded and it is using the 53 multiplier. Adaptive voltage adjusts for this automatically.

Are you using the Windows Balanced power plan or the High Performance power plan? If you want to save power I would enable the core C states in the BIOS. No need to slow the CPU down to save power as long as the C states are enabled.
So the first thing I'll say, you gathered a lot of information from that, as to be expected, but I'll address some of these for the sake of clarity. I'm not sure "what else" could have be affected by this 'bug" but it seems more is different now based on what you've observed.

Firstly, my long duration power limit IS set to 4096w (i guess where you say 4095 is just mobo specific). I had messed around with the short duration power limit while trying to troubleshoot this issue on my own, but it seems to have only made my "idle" clocks go up to around 2000MHz so I reverted it to "auto". Which leads well into the C-States. I have everything configured so that it is in as low of a power state as possible when it's idling or I'm browsing on chrome. The power plan itself is on balance, but I manually adjusted some of the settings such as minimum and maximum CPU power to 5% and 100% respectively, as well as sleep mode and some other things. I also, and I'm going to get this confused, adjusted the C-State and speedstep(I think?) to further lower idle power draw and temps.

So in regards to ThrottleStop, I did open when my CPU was still at 5.1GHz just to learn to navigate it, then actually ran the test once it was "limited" to 4.9GHz. Since you say if I make a change in the BIOS I'll need to delete the .ini, I'm unsure if this was affected here as my clock speed was essentially reduced.

With that said you mentioned power limits and I'm apparently throttled by them.. however I mentioned earlier that I do have the long duration power limit set to 4096w. So if I read what you said correctly then that should overwrite the PL1 and PL2 states but isn't? I suppose this could also be changed by whatever it is that's affecting my CPU?


You say it's possible that it's overwriting my turbo values, and it seems that my power limits are changed as well (unless I'm misinterpreting you).

Lastly when it comes to voltage and whatnot. I did this overclock maybe a year and a half ago and I spent over a week on it making sure temps, speeds, and voltages were all where I wanted them. Then maybe... 3 months ago I began getting crashing and I solved it by reducing the ring ratio down a bit (which was overclocked as well). However I'm certain that it's at least 99.999999% stable now. I did think that before but I suppose degradation can happen?

In conclusion.. it seems that (potentially) my power limits as well as my clock speeds are being reduced? Any further advice?

Thanks for your help again!
 

uWebb429

Estimable
my long duration power limit IS set to 4096w
ThrottleStop shows that the CPU power limits are not set to 4096W. They are both set to 125W.



If you want to try and troubleshoot this issue, exit ThrottleStop, delete the ThrottleStop.INI config file, reboot, go into the BIOS and set the power limits to whatever values you like. When you start back up, immediately run ThrottleStop so it can read the power limits from the CPU. This will confirm if the BIOS is setting the power limits correctly.

If everything is OK, start the LoL client and watch to see if the MSR PL1 and PL2 power limits change. Exit the LoL client and once again check to see if these power limits have changed.

It is physically impossible to set the turbo power limit register to 4096W. The register is not big enough to hold a value that big. I have no idea what number the BIOS is actually writing to the power register. To avoid any problems, try using 4095W for PL1 and PL2 in the BIOS. 4095W fits in this register. 4096W does not.

That is problem one. The other problem is the turbo groups are set to default values according to ThrottleStop. To troubleshoot, do the same sort of testing as above. Delete the ThrottleStop.INI config file, reboot, make changes in the BIOS to your turbo groups and then look in the FIVR window to see what these are actually set to.

If the Turbo Groups look the same as what you set in the BIOS then do the same sort of testing with ThrottleStop. Exit ThrottleStop, delete the INI config file, start the LoL client and then start ThrottleStop to see if the turbo groups have changed.

I believe your computer has two separate problems that are limiting the maximum CPU speed.

What turbo groups are you setting in the BIOS?
 

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
ThrottleStop shows that the CPU power limits are not set to 4096W. They are both set to 125W.



If you want to try and troubleshoot this issue, exit ThrottleStop, delete the ThrottleStop.INI config file, reboot, go into the BIOS and set the power limits to whatever values you like. When you start back up, immediately run ThrottleStop so it can read the power limits from the CPU. This will confirm if the BIOS is setting the power limits correctly.

If everything is OK, start the LoL client and watch to see if the MSR PL1 and PL2 power limits change. Exit the LoL client and once again check to see if these power limits have changed.

It is physically impossible to set the turbo power limit register to 4096W. The register is not big enough to hold a value that big. I have no idea what number the BIOS is actually writing to the power register. To avoid any problems, try using 4095W for PL1 and PL2 in the BIOS. 4095W fits in this register. 4096W does not.

That is problem one. The other problem is the turbo groups are set to default values according to ThrottleStop. To troubleshoot, do the same sort of testing as above. Delete the ThrottleStop.INI config file, reboot, make changes in the BIOS to your turbo groups and then look in the FIVR window to see what these are actually set to.

If the Turbo Groups look the same as what you set in the BIOS then do the same sort of testing with ThrottleStop. Exit ThrottleStop, delete the INI config file, start the LoL client and then start ThrottleStop to see if the turbo groups have changed.

I believe your computer has two separate problems that are limiting the maximum CPU speed.

What turbo groups are you setting in the BIOS?
Thanks again. Okay so I have a few things at this point.

Firstly the "long duration power limit" sets itself to 4096w, so if I type 9999 just to max it out, it reverts to 4096w. I took a picture of that in BIOS, but I'm apparently tech illiterate because I don't know how to insert locally stored photos onto these comment sections. You'll just have to trust me on that I suppose. However it does read in ThrottleStop as 4095w.

With that said, I reset but DID NOT change anything in the BIOS before running the TS Bench test again. with these results.

TS Bench: Part way through the run https://gyazo.com/625abd93d6164f9cb7fa5f3a322e8d39 and towards the end of the run https://gyazo.com/ac727a6f2c1399e4954823a66280871f

TPL: https://gyazo.com/a19f72461017acac002c5345d4683a6f

FIVR: https://gyazo.com/c76913d52a8288f4166e5c6775c59ae2

TPL After opening and closing the LoL client: https://gyazo.com/f063fb7dd65c72919ea5633e02fd494b

That's just if you would like to compare to the previous, I looked at it best I could but I don't know THIS much about CPUs to draw any meaningful inclusions. So if you feel like it or not, that's fine, no sweat. At the very least that does confirm that the LoL client is bringing down the power limit as well as the CPU Ratio.

Lastly I'm unsure what you mean by Turbo Groups? I think I'm unfamiliar with the term, but then again, I did already say I was tech illiterate. ;)

Thanks again, I truly appreciate the help.
 
Last edited:

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
Thanks again. Okay so I have a few things at this point.

Firstly the "long duration power limit" sets itself to 4096w, so if I type 9999 just to max it out, it reverts to 4096w. I took a picture of that in BIOS, but I'm apparently tech illiterate because I don't know how to insert locally stored photos onto these comment sections. You'll just have to trust me on that I suppose. However it does read in ThrottleStop as 4095w.

With that said, I reset but DID NOT change anything in the BIOS before running the TS Bench test again. with these results.

TS Bench: Part way through the run https://gyazo.com/625abd93d6164f9cb7fa5f3a322e8d39 and towards the end of the run https://gyazo.com/ac727a6f2c1399e4954823a66280871f

TPL: https://gyazo.com/a19f72461017acac002c5345d4683a6f

FIVR: https://gyazo.com/c76913d52a8288f4166e5c6775c59ae2

TPL After opening and closing the LoL client: https://gyazo.com/f063fb7dd65c72919ea5633e02fd494b

That's just if you would like to compare to the previous, I looked at it best I could but I don't know THIS much about CPUs to draw any meaningful inclusions. So if you feel like it or not, that's fine, no sweat. At the very least that does confirm that the LoL client is bringing down the power limit as well as the CPU Ratio.

Lastly I'm unsure what you mean by Turbo Groups? I think I'm unfamiliar with the term, but then again, I did already say I was tech illiterate. ;)

Thanks again, I truly appreciate the help.
Another point to mention that I kind of forgot to elaborate on.. If I reopen the client, and for as long as it's open, the power limits as well as the CPU clocks go back to where they should be.
 

uWebb429

Estimable
I don't know THIS much about CPUs to draw any meaningful inclusions.
I do not think you need to be a computer brain surgeon to see what is going on. Opening and closing the LoL client is changing the PL1 and PL2 power limits from 4095W to 125W. That kills full load performance. This is something that should definitely not be happening. If you set the power limits to 4095W in the BIOS, no software without your permission should ever be changing these limits.

Turbo Groups
Turbo Groups is just Intel's new name for the turbo multipliers. Your initial screenshot after booting up looks correct. The CPU is being told to use the 51 multiplier no matter how many cores are active. This is what you set in the BIOS.



The problem is that after running the LoL Client, these values are reset to the 10900K default values. This will limit your CPU to the 49 multiplier when all cores are active which is not what you set in the BIOS.

I guess you can try contacting the developers of the LoL client to ask them what on earth is going on. Forcing users to run their crappy software all of the time just to keep your CPU running at the values set in the BIOS is ridiculous. Good work tracking down this major bug. Perhaps the LoL client has some sort of INI option or registry option available to prevent this from happening. No software should be touching the power limits or the turbo groups.
 
Last edited:

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
I do not think you need to be a computer brain surgeon to see what is going on. Opening and closing the LoL client is changing the PL1 and PL2 power limits from 4095W to 125W. That kills full load performance. This is something that should definitely not be happening. If you set the power limits to 4095W in the BIOS, no software without your permission should ever be changing these limits.


Turbo Groups is just Intel's new name for the turbo multipliers. Your initial screenshot after booting up looks correct. The CPU is being told to use the 51 multiplier no matter how many cores are active. This is what you set in the BIOS.



The problem is that after running the LoL Client, these values are reset to the 10900K default values. This will limit your CPU to the 49 multiplier when all cores are active which is not what you set in the BIOS.

I guess you can try contacting the developers of the LoL client to ask them what on earth is going on. Forcing users to run their crappy software all of the time just to keep your CPU running at the values set in the BIOS is ridiculous. Good work tracking down this major bug. Perhaps the LoL client has some sort of INI option or registry option available to prevent this from happening. No software should be touching the power limits or the turbo groups.
I gotcha, and one final thanks for helping me here. Glad I have something concrete to show now. I contacted Riot Support this morning (the devs) so I guess I'll see how they interpret this.

If I find a solution, or they admit it's a mistake on their end, whatever, I'll post here in the off chance that someone has a similar issue.
 

uWebb429

Estimable
@Savage One

Until this gets fixed, if it ever gets fixed, you can use ThrottleStop to reset the power limits without having to reboot. Open the TPL window and clear the Disable Controls box. Now you can set the MSR PL1 and PL2 power limits to whatever you like. 4095 works well to avoid any throttling. ThrottleStop will maintain these values while it is running.

If you use the Lock option, the LoL client will not be able to change the power limits from what you have selected.

You should be able to set the Turbo Groups to 51 and ThrottleStop will work to maintain this setting too. ThrottleStop is very efficient and takes up next to nothing for memory or CPU resources so it is OK to leave it running, minimized to the system tray. In the Options window you can set ThrottleStop so it shows the CPU temperature in the system tray.

I would use the Task Scheduler so ThrottleStop starts every time you boot up and log in to your account.

Edit - Here is the easy way to tell the CPU to use the 51 multiplier no matter how many cores are active.
Only Group 0 needs to be defined. On my 10850K, all of the other Groups can be set to 0.

 
Last edited:

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
@Savage One

Until this gets fixed, if it ever gets fixed, you can use ThrottleStop to reset the power limits without having to reboot. Open the TPL window and clear the Disable Controls box. Now you can set the MSR PL1 and PL2 power limits to whatever you like. 4095 works well to avoid any throttling. ThrottleStop will maintain these values while it is running.

If you use the Lock option, the LoL client will not be able to change the power limits from what you have selected.

You should be able to set the Turbo Groups to 51 and ThrottleStop will work to maintain this setting too. ThrottleStop is very efficient and takes up next to nothing for memory or CPU resources so it is OK to leave it running, minimized to the system tray. In the Options window you can set ThrottleStop so it shows the CPU temperature in the system tray.

I would use the Task Scheduler so ThrottleStop starts every time you boot up and log in to your account.

Edit - Here is the easy way to tell the CPU to use the 51 multiplier no matter how many cores are active.
Only Group 0 needs to be defined. On my 10850K, all of the other Groups can be set to 0.

Cool, I'll see what I can do. Thanks for the info!
 
Reactions: uWebb429

Savage One

Honorable
Apr 2, 2016
149
3
10,595
1
An update for anyone who may eventually stumble upon this thread:

Riot looked at the issue for me, I submitted game logs, throttlestop screenshots as I did here, and obviously explained the issue in as much detail as possible.

However their conclusion was, and I quote this verbatim, "Our programs are designed to work with standard clocks, exclusively. Overclocks are not supported. These two things together are why strange things occur. "

They looked at the issue, decided they didn't wanna do anything about it, and fed me this line. So you may take whatever you will from that, hopefully either I'm alone in this issue, or someone will find a way around it eventually.

EDIT: UPDATE: Only god may know why, but it appears that uninstalling the game AND PUTTING IT ON ANOTHER DRIVE fixes this issue. Simply uninstalling / reinstalling did not fix it for me, but only UNINSTALLING THEN REINSTALLING TO ANOTHER DRIVE worked for me. I'm glad I found a solution, I hope this helps someone else.
 
Last edited:

ASK THE COMMUNITY