[SOLVED] I think I bricked my b550 when I was doing a bios update

NoobishPCGamer

Reputable
Apr 17, 2017
41
0
4,540
1
So I was updating my b550 aorus pro ac because the oc on my ram wasn't working but after the update finished my screen turned black and I waited five minutes for a response but nothing happened/ no video output on my monitor whatsoever so I decided to restart my pc just for nothing to happen again. Any tips on what I can do?
 

NoobishPCGamer

Reputable
Apr 17, 2017
41
0
4,540
1
I did not brick my motherboard and the BIOS Update did not fail. After hours of trying to figure out what happened, it did not cross my mind that after the update I guess the configs I had put in place before were reset. Since the B550 has a 4th gen pcie slot my vertical gpu stand with its 3rd gen pcie riser was not compatible. So I just put I plugged in my card normally and it booted properly!
 

NoobishPCGamer

Reputable
Apr 17, 2017
41
0
4,540
1
You can attempt to try a CMOS reset. If that doesn't work, that board should have bios flashback capabilty, so you can try to flash it that way. Your manual will state how to do it.
Yes I'm currently trying to do that using q-flash but It seems to be not working. The instructions were to download the correct file and to rename it to GIGABYTE.bin and q-flash is supposed to detect it. Ive been doing it for a few minutes and the only thing that's happened so far are my mouse and keyboard turning back on
 

dimtodim

Respectable
Sep 4, 2018
680
64
1,990
14
So I was updating my b550 aorus pro ac because the oc on my ram wasn't working but after the update finished my screen turned black and I waited five minutes for a response but nothing happened/ no video output on my monitor whatsoever so I decided to restart my pc just for nothing to happen again. Any tips on what I can do?
check this maybe help you
View: https://www.youtube.com/watch?v=bOPQAaLlOWA
 

dimtodim

Respectable
Sep 4, 2018
680
64
1,990
14
Watched the video, his problem was the same as mine but unfortunately I don't understand how he fixed it. I tried the obvious steps like removing the cmos battery but that didn't help. I'm trying to do Q-flash but the QF-LED on the motherboard isn't flashing
He first try flash last ver of bios and bricked... After that he flash again with older ver... see what version u must install before last...
 

NoobishPCGamer

Reputable
Apr 17, 2017
41
0
4,540
1
He first try flash last ver of bios and bricked... After that he flash again with older ver... see what version u must install before last...
Hello, I just tried installing the latest version of my bios but It's still not working since I'm getting no post. Are you telling me to keep installing older versions if the last ones didn't work?
 
Oct 12, 2020
6
1
10
0
Lol, Gigabyte boards are weird, I think you have to remove anything in USB and SATA external ports for board to reset or even flash.
Edit: from watching building videos, also make sure you got the proper chipset, amd and intel as they both have the same bios names, but different chipsets.
Edit: I forgot to mention except for mouse and keyboard.
 

NoobishPCGamer

Reputable
Apr 17, 2017
41
0
4,540
1
You can attempt to try a CMOS reset. If that doesn't work, that board should have bios flashback capabilty, so you can try to flash it that way. Your manual will state how to do it.
So I've flashed it but I'm still getting no post. I flashed it through q-flash plus and I verified that the LED was blinking but not video output after restarting still
 

NoobishPCGamer

Reputable
Apr 17, 2017
41
0
4,540
1
I did not brick my motherboard and the BIOS Update did not fail. After hours of trying to figure out what happened, it did not cross my mind that after the update I guess the configs I had put in place before were reset. Since the B550 has a 4th gen pcie slot my vertical gpu stand with its 3rd gen pcie riser was not compatible. So I just put I plugged in my card normally and it booted properly!
 

ASK THE COMMUNITY