Question I think I bricked my half-baked linux installation and I can't use grub resdue

Aug 21, 2021
1
0
10
0
TLDR: Entered grub rescue to fix my system, tried to install normal module. Didn't work. Need help figuring out what to do next.

As the title says.

About a year ago, I took an old laptop I had and tried to install a linux distribution into it (elementary OS). This was my first time installing a linux distro ever, so I might have made some mistakes when I was trying to install the OS from my usb.

After what I thought was the last step of the installation, I restarted my laptop and ended up on something called grub rescue terminal. So, I started researching what the heck grub is and ended up on the conclusion that I * up real bad somewhere during my installation.

Started trying to fix my system with grub, but unfortunately, anything I ever did ended up in failure. Take a look at the image. View: https://imgur.com/a/4KLZ9ic


I already found the area where my os is stored, so I set the root, set the prefix, and tried to install the normal module. No luck there.

And that's where I'm having problems. I can't fix my system without the normal module, and I can't install the normal module. What do I do?
 
Last edited by a moderator:

ASK THE COMMUNITY

TRENDING THREADS