Question i think i broke my new LED Hub

Sep 6, 2020
2
0
10
0
So i bought a new pc case (Sharkoon REV200) and i was plugging in the cables , the fan cables where all plugged in a rgb hub in the back of the case which was included.
There was a cabel coming out of it with two endings ,one said VDG or something like that (it was a small 3 pin) and the other ending was a regular 3 pin fan header (the ones used for smart rgb´s).
The whole thing was powered by a Sata cable and while the PSU was still on i plugged the 3 pin fan header back in the fan hub itself.
I did that cuz first when i powered it up only the rgb´s where on but no fans spinning (the reason beeing that i didnt connect them to the PSU) and then i connected all fan cabels to the PSU and the 3 pin header that came out of the fan hub back in the fan hub , no idea why.
And now there is no rgb but the fans are spinning.
How do i get the rgb´s ba ck on?
Is something broken?
Please Help

Thanks!
 

Aeacus

Glorious
Ambassador
while the PSU was still on i plugged the 3 pin fan header back in the fan hub itself.
Here, i'm amazed why people doesn't bother to read manuals when assembling their hardware. If you were to read your PC case manual and follow the instructions, where all is written, there wouldn't be such dumb moves.

In any event, to know what the "VDG" is, take out your PC case manual and read Page 9. It is clearly stated there.

How do i get the rgb´s ba ck on?
I take that you connected the reset button wire to the 2-pin header on RGB hub, as stated in PC case manual. If so, read the PC case manual, Page 10 to learn how to turn your RGB LEDs back on.

That is, if you didn't fry your RGB hub with backfeed loop, by plugging the ARGB header back into the RGB HUB.
If you did fry your RGB hub with that dumb move, then this is what i call a Life's Tax.
 
Thread starter Similar threads Forum Replies Date
S Cases 4

ASK THE COMMUNITY

TRENDING THREADS