Question I think i port forwarded the port 25565 so i can run the MC server, but when testing it says its closed. What do i do ?

Oct 24, 2021
11
0
10
0
Hi,
i have been dealing with a problem lately.
I have got myself a TP-LINK Archer C80 and i bought it beacuse the settings seemed easy. They are, but not working? Let me show you my NAT port forward settings:

Service name : HTTP
IPv4 ADDRESS : 192.168.1.102
External port: 25565
Internal port : 25565
Protocol: TCP
Enable this entry: Yes


It should be working or am i missing something? why isnt it working
 
There are 2 other very common things that can cause this.

First check that you actually have a public IP address. Your router should show the IP assigned to WAN port of your router by the ISP. You can lookup what is public/private ip but a simpler test is to compare this ip with what you see on a site like whatsmyip. If the addresses are not the same you do not have a public IP.
Without a public IP port forwarding will never work.

Next there has to a program actually active on the port to be able to respond to test traffic. The firewall on the machine must also allow the traffic into and out of the machine.
 
Oct 24, 2021
11
0
10
0
There are 2 other very common things that can cause this.

First check that you actually have a public IP address. Your router should show the IP assigned to WAN port of your router by the ISP. You can lookup what is public/private ip but a simpler test is to compare this ip with what you see on a site like whatsmyip. If the addresses are not the same you do not have a public IP.
Without a public IP port forwarding will never work.

Next there has to a program actually active on the port to be able to respond to test traffic. The firewall on the machine must also allow the traffic into and out of the machine.
So I should use the public IP addres instead of IPv4?
 
Oct 24, 2021
11
0
10
0
I am having a problem with port forwarding my MC server.
I port forwarded TCP and UDP 25565 ports in my router, opened up the server so it should be listening? but on port checker it says its closed.
I am doing all the changes on my pc, whiches internet connection is expanded by 1 extendor and a router. I have a static ip, it is changing in ipconfig /all
I desperatly need help.
 
Oct 24, 2021
11
0
10
0
There are 2 other very common things that can cause this.

First check that you actually have a public IP address. Your router should show the IP assigned to WAN port of your router by the ISP. You can lookup what is public/private ip but a simpler test is to compare this ip with what you see on a site like whatsmyip. If the addresses are not the same you do not have a public IP.
Without a public IP port forwarding will never work.

Next there has to a program actually active on the port to be able to respond to test traffic. The firewall on the machine must also allow the traffic into and out of the machine.
Hello, I checked. When I go to STATUS page, the ip shown is like 192.168.1.xxx, but ono whatismyip.com it is like 97.39.xx.xx . What is that?
 

kanewolf

Titan
Moderator
Hello, I checked. When I go to STATUS page, the ip shown is like 192.168.1.xxx, but ono whatismyip.com it is like 97.39.xx.xx . What is that?
THAT is why you can't port forward. Your WAN IP address is not your public IP address. That is because there is another router between your router and the internet. If you believe your router is connected directly to the ISP, then you need to contact them to see if you can be switched to a public IP address.
 
Oct 24, 2021
11
0
10
0
THAT is why you can't port forward. Your WAN IP address is not your public IP address. That is because there is another router between your router and the internet. If you believe your router is connected directly to the ISP, then you need to contact them to see if you can be switched to a public IP address.
OH YEA i have a router in my room set to repeat... so if i go down to my moms office where the router connected to the modem is, that should work?
 

kanewolf

Titan
Moderator
OH YEA i have a router in my room set to repeat... so if i go down to my moms office where the router connected to the modem is, that should work?
Two things. First you should configure your "room" router as an access point. Then you don't have to deal with it when port forwarding. You have to do your port forwarding on the router connected to the ISP. But you do have to check the WAN IP there also. It might not be public either.
 
Oct 24, 2021
11
0
10
0
Two things. First you should configure your "room" router as an access point. Then you don't have to deal with it when port forwarding. You have to do your port forwarding on the router connected to the ISP. But you do have to check the WAN IP there also. It might not be public either.
If i want to setup access point, it says i need an ehternet cable...this is the other side of the house, not possible
 
Oct 24, 2021
11
0
10
0
You are using this second router as a wireless extender ?
Well my main router is lets say making the WiFi1. It reaches my room, but hardly. So i bought an ASUS router, it is collecting the wifi1 and making wifi2, meanwhile i am ethernet connected to the ASUS router
 
Oct 24, 2021
11
0
10
0
You're double NAT'd bro.

Set the asus router as an access point, and use the DHCP off your mom's router. Then do all the port forward settings on your mom's router which is connected to the main internet.
what or how i should do it? I am a begginer when it comes to these things...i just wanna host a mc server
 

gggplaya

Distinguished
what or how i should do it? I am a begginer when it comes to these things...i just wanna host a mc server
Under Operation Mode, you want to set you TPlink router to AP mode, see instructions here: https://www.tp-link.com/us/support/faq/2420/

AP mode will disable the internet NAT and DHCP on your tplink router. So now your mom's router will handle all NAT and DHCP duties. You'll likely have a different IP address after the change.

On your mom's router, you want to set up port forwarding to your computer that is hosting minecraft.
 

kanewolf

Titan
Moderator
Under Operation Mode, you want to set you TPlink router to AP mode, see instructions here: https://www.tp-link.com/us/support/faq/2420/

AP mode will disable the internet NAT and DHCP on your tplink router. So now your mom's router will handle all NAT and DHCP duties. You'll likely have a different IP address after the change.

On your mom's router, you want to set up port forwarding to your computer that is hosting minecraft.
Except he is using WIFI input. I don't think AP mode will work for that.
I had suggested that above and the OP said they didn't have a cabled connection to the primary router.
 
Oct 24, 2021
11
0
10
0
Under Operation Mode, you want to set you TPlink router to AP mode, see instructions here: https://www.tp-link.com/us/support/faq/2420/

AP mode will disable the internet NAT and DHCP on your tplink router. So now your mom's router will handle all NAT and DHCP duties. You'll likely have a different IP address after the change.

On your mom's router, you want to set up port forwarding to your computer that is hosting minecraft.
BUT IF I WANT TO MAKE an Access point on my Asus router, i need an ethernet cable, which i dont have. The asus router is picking up signal from moms router and erthernet connection to my pc
Except he is using WIFI input. I don't think AP mode will work for that.
I had suggested that above and the OP said they didn't have a cabled connection to the primary router.
Ok i think you guys dont understand. My moms router is connected to the modem. It is giving away WIFI1. In my room, i have my router, which is wirelessly catching that network and repeating it with WIFI1_RPT
 
If it is truly setup as a repeater then you must do all the port forwarding in the main router. The "repeater" should just pass the data through. It does not run NAT. Best option is to remove your secondary router and get the port forwarding working even on a very weak wifi signal. Once you get that working you likely can just start using the repeater and the port forwarding will work.

I am not sure what you think are are accomplishing doing this. If you place the second router/repeater in your room it gets the same crappy signal from the main router as your PC does. It might seem like you get a stronger signal but the quality of the data inside the signal is still poor because of the poor data reception from the main router. In most cases it will actually make the data throughput worse when you install it like this. The optimum placement of a repeater is generally 1/2 between. It must be placed in a location that it can receive good signal from the main router and still be able to send the data to your room....in your case is close enough that you can run the ethernet cable.
 

ASK THE COMMUNITY