[SOLVED] I think my BIOS chip is failing ?

Hello, last night my MSi Z68A GD65 (G3) suddenly blackscreens and fans run at full speed, i decided to power it off completely and try to unplug all ram and the 8 pin for cpu, then after some moment i plug it back in and it board power on by itself! then i tried to remove cmos, then direct flash the 1st bios chip using stock bios i save, placing all rams and cpu eps, and it worked.., and i decided to shut the pc off. This morning, the pc wont boot with the same symptomps again, could this be a failing Bios Chip? I never ecountered this kind of problem before.
Z68? Have you tried replacing the CMOS battery with a new one? That's a pretty old board and it's very likely the CMOS battery is becoming weak or failing.
i did use a newer cmos battery i bought last year, still sealed

The only thing that made it alive is, reflash it using ch341a, but then it would fail again.. i had a tought was it bios chip failing, or the caps below the chips are failing...
Test the CMOS battery with a volt meter. I've bought plenty of CR2032 batteries that were weak right out of the package because they don't tend to sell quickly and sit on the shelves for a long time.
Just tested it on my other mobo, same lga 1155, B75M HD3 to be exact, it does work (this board got no battery, i forgot where did i put it last time i took this thing off) and saved the settings.. i tested using multitester and it still do 3v range.

oh also check this vid out, now reflashing bios did not work at all in any means (before (last night to be exact), wiping bios then writing it fixed it tempoary)
I'd say it's a failing board then.
Yeah, after several attempts of replacing the bios chip, it didnt work... but hey got a new board for near the same price i bought it. it's H77-DS3H and i could tell you this thing running great, resizable bar is possible, despite need to sacrifice the OC capability :")

Also got a new GPU as well, RX 590GME for just $81 in my country!
Last edited: