Question I think my BIOS is corrupted should I update it?

Oct 23, 2015
5
0
10,510
0
Right.

At christmas I installed my new Corsair MP510 240GB M.2 drive. I tried to boot up the pc but I got a black screen saying not boot media detected. So I removed the M.2 drive and my other hard drives so that just my old SSD with windows installed on it was connected to the PC. I got the same message again. When I next booted it up I tried to access the BIOS thinking that it must have automatically changed my settings but when I press the DEL, F2 or the key for boot order all I get is either the boot screen but you can't do anything (frozen) or just a black screen with no text or anything. When I press the DEL key to enter BIOS the display on the motherboard displays A9 which means that BIOS config has started - but I get no BIOS GUI.

Since then I reconnected the M.2 drive and removed all the others and installed windows from a USB stick. The PC runs ok but I still can't enter the BIOS. When it starts up it stays on the splash screen for about 10 seconds before it boots into windows. I want to sort out the problem. I think the BIOS is probably corrupted. Before any of this I deleted the '@ BIOS' utility and thinking maybe that has something to do with it.
I'm thinking of flashing the BIOS with the most recent update but I'm worried it will make things worse. Opinions? Should I leave it?

Looking to upgrade with a new MOBO, CPU and case this year anyway but it still plays on my mind that one day my PC might not work and I use it everyday.

Spec list:

MOBO: Gigabyte Z170 Gaming 7 - BIOS Version F21 (most recent is F22m)
CPU: Intel i7 6700
RAM: Corsair Vengence RGB 3200 16GB
PSU: Corsair RM650i
GPU: Gigabyte RTX2060 OC
M.2:Corsair MP510 240GB
SSD: Samsung 850 500GB
2x WD Blue: 1x 1TB, 1x 2TB
 
It's kind of hard to put a diagnose only based on the fact that the bios screen won't load. Try these steps attempting to get to bios screen:
  • Disconnect all storage devices.
  • Remove the GPU, use the onboard gpu instead
  • Clear cmos (look up in the mobo user manual on howto)
  • Remove one RAM stick.
  • Swap ram sticks.
If and when you get it to work, I'll suggest you do an additional integrity test of RAM, using an utility such as Memtest86+. Just for having ruled out bad ram.
 

ASK THE COMMUNITY

TRENDING THREADS