Question I think my GPU might be dying

Foolish Munkey

Honorable
Oct 31, 2014
19
0
10,510
0
Hey everybody!

Let me get my specs out the way.
Ryzen 3600x
16 GB of DDR4 corsair ram (dual)
RX 480 8GB Reference Card (19.12.3 Drivers)
XFX 850W gold plus

Recently upgraded my CPU from an i5 to a new ryzen chip during the x-mas sales. After getting BSoD, I refreshed Windows 10 and it fixed all my problems for a while. Recently started playing some old games like Viscera Cleanup Detail on Steam and noticed some random crashes. Fixed the files, but I also noticed some of my YouTube videos having a stutter in the audio and some weird flickering with the browser. At the time it was going on, I was running a torrent with Norton and thought some added feature made torrenting throttle performance or something.

I uninstalled all my torrent clients and restarted my PC again. Everything was fine, until I noticed it appearing after playing a taxing game. With the CPU running at 20% my GPU is nearly at 90-95%. I checked the thermals and saw the temps ranging around 85-95 degrees C at times. When I have a drop in performance, a reboot seems to clear up the issue, but I'm hearing weird audio problems and performance hits a little more at a time.

Long story short, should I go shopping for a new GPU? Is there something else going on? What should I do to test? Is my GPU just old? I have an old RX 280 in the closet if I need to test it against something.

Thank you for your time.
 

Foolish Munkey

Honorable
Oct 31, 2014
19
0
10,510
0
When you refreshed Windows 10 did you install your motherboard chipset drivers and GPU drivers?
Yes...would be the answer I would love to give but something weird happen. To double make sure, I went to my app center to check my drivers and I have no Gigabyte related apps or features in the app center. I go to the website and redownload the chipset because why the hell not. I run it, it completes, and reboots my PC. I go to the AMD drivers and it's clocked back to a previous driver with the older format and not the new one for the XT line...but I had the new one with the boost features and such. Again, redownload it for the hell of it and I'm updated now...I think.
 

ASK THE COMMUNITY

TRENDING THREADS