Question I think my integrated soundcard is dead

Nov 14, 2020
2
0
10
0
Hello so i think my integrated sound card is dead because when i connect my headset no sound is coming out of them just a high pitch noise.This is happening since my gtx 1060 died after that i upgraded to a 1660 but the high pitch noise is still there, no changes ,before the death of 1060 it was fine.The headset is working fine on other pcs etc...What can i do any ideas? I tried reinstalling the drivers ,not working.Should i buy a new mobo?
 
Last edited:

General Kenobi

Respectable
Sep 19, 2018
635
130
2,140
29
Hello so i think my integrated sound card is dead because when i connect my headset no sound is coming out of them just a high pitch noise.This is happening since my gtx 1060 died after that i upgraded to a 1660 but the high pitch noise is still there, no changes ,before the death of 1060 it was fine.The headset is working fine on other pcs etc...What can i do any ideas? I tried reinstalling the drivers ,not working.Should i buy a new mobo?
Hello there!!
I have some questions;
1.Does any other headset work with your pc??
2.Did you check the front io cables is it securely connected onto your Mobo?
3.Did you check connecting your headset on your mobo's back io?
 
Nov 14, 2020
2
0
10
0
Hello there!!
I have some questions;
1.Does any other headset work with your pc??
2.Did you check the front io cables is it securely connected onto your Mobo?
3.Did you check connecting your headset on your mobo's back io?
Yes i checked all no headset working and i only use the back conection but the front does not work too
 

ASK THE COMMUNITY

TRENDING THREADS