Question I think my power supply cooked my motherboard ?

Warpspasm

Distinguished
May 28, 2003
355
0
18,780
0
The other day I turned on my PC and it made an pop and blew a circuit breaker in the house. Flipped the breaker back on and PC wouldn't fire up. It's a unit I built about 7 years ago with a GA-Z97X-GAMING 7 mobo and a Intel Core i5-4690K . I bought a new Super Flower 750W Gold power supply and installed it. When I booted the computer I was met with "No bootable device is detected and sent to BIOS. I have one solid state and one regular HD installed, but nothing shows in BIOS. I also can't find my GPU listed anywhere. They no longer make this mobo, but I've seen used ones on the market. I'm not really sure what to do at this point. Any help would be greatly appreciated. Thanks
 
The other day I turned on my PC and it made an pop and blew a circuit breaker in the house. Flipped the breaker back on and PC wouldn't fire up. It's a unit I built about 7 years ago with a GA-Z97X-GAMING 7 mobo and a Intel Core i5-4690K . I bought a new Super Flower 750W Gold power supply and installed it. When I booted the computer I was met with "No bootable device is detected and sent to BIOS. I have one solid state and one regular HD installed, but nothing shows in BIOS. I also can't find my GPU listed anywhere. They no longer make this mobo, but I've seen used ones on the market. I'm not really sure what to do at this point. Any help would be greatly appreciated. Thanks
It's not unheard of a lousy PSU fries some other component. It's often overlooked but a PSU is very, very important part and shouldn't skimp on it.
 

Warpspasm

Distinguished
May 28, 2003
355
0
18,780
0
I had a good power supply, it lasted at least 7 years. It was a 650W Corsair.
When I turn on my PC everything lights up, all of the fans come on, including the ones on the GPU and the CPU heat sink. I'm weak when it comes to understanding BIO, but I think it sees my memory and CPU. Could the power supply just take out the drive and GPU part of the mobo? Is there a way check to see if the drives and GPU are still good without trying them in another board? Is there a way to test the SATA and GPU slots to see if they're working properly?
 
I had a good power supply, it lasted at least 7 years. It was a 650W Corsair.
When I turn on my PC everything lights up, all of the fans come on, including the ones on the GPU and the CPU heat sink. I'm weak when it comes to understanding BIO, but I think it sees my memory and CPU. Could the power supply just take out the drive and GPU part of the mobo? Is there a way check to see if the drives and GPU are still good without trying them in another board? Is there a way to test the SATA and GPU slots to see if they're working properly?
Yes, there are several voltages coming out of PSU for different parts, so yes it's possible to take out any part of PC leaving others untouched.
 

Warpspasm

Distinguished
May 28, 2003
355
0
18,780
0
Thanks. So, the questions I’m now asking myself are:
Do I buy a used mobo and see if that fixes it?

Find a new motherboard that will be compatible with my chipset, GPU and DDR3 RAM?

Replace everything?

I don’t really need a faster machine, as this one met all of my needs. But, I don’t want a less powerful either. So, I want to keep any components that are still good.

I welcome and am open to any wisdom or advice to help me make this decision.
 
Thanks. So, the questions I’m now asking myself are:
Do I buy a used mobo and see if that fixes it?

Find a new motherboard that will be compatible with my chipset, GPU and DDR3 RAM?

Replace everything?

I don’t really need a faster machine, as this one met all of my needs. But, I don’t want a less powerful either. So, I want to keep any components that are still good.

I welcome and am open to any wisdom or advice to help me make this decision.
Frankly, you would be better off using this situation and build/get new system. It's not all about faster but with latest one you get newer tech and options, able to run Windows 11 etc.
 
When I booted the computer I was met with "No bootable device is detected and sent to BIOS. I have one solid state and one regular HD installed, but nothing shows in BIOS. I also can't find my GPU listed anywhere.
If you can boot into BIOS, then motherboard more or less works (it is not fried).

If your drives are not being detected, this could mean -
you either have not connected them properly or​
drives are dead.​
Recheck connections to your drives - power and data cables. Try different sata ports on motherboard.

What gpu are you using?

Can you show a photo of inside view of your system? (to see, how everything is connected)
 
I had a good power supply, it lasted at least 7 years. It was a 650W Corsair.
When I turn on my PC everything lights up, all of the fans come on, including the ones on the GPU and the CPU heat sink. I'm weak when it comes to understanding BIO, but I think it sees my memory and CPU. Could the power supply just take out the drive and GPU part of the mobo? Is there a way check to see if the drives and GPU are still good without trying them in another board? Is there a way to test the SATA and GPU slots to see if they're working properly?
You could inspect the motherboard for scorch marks, black marks or discoloration, or other signs of damage
 

Warpspasm

Distinguished
May 28, 2003
355
0
18,780
0
If you can boot into BIOS, then motherboard more or less works (it is not fried).

If your drives are not being detected, this could mean -
you either have not connected them properly or drives are dead.Recheck connections to your drives - power and data cables. Try different sata ports on motherboard.

What gpu are you using?
I398659, member: 1990548"]

I actually didn't disconnect anything except the power cord, and going from the old power supply to the motherboard and and GPU. I went back and l checked the connections to the drives, GPU and motherboard after reading your response and they seem ok. The one think I did have a question about when I originally hooked up the new power supply was the connection going to the GPU of the new supply had 6+2 pin plugs on both ends. My original had a 6+2 where it connected to the GPU, but only 6 pin where it when into the power supply. I plugged in the 6+2 on both ends on my new connection.


BTW - if old and new PSU were both modular, you have to use original psu cables for the new PSU. You can not reuse old modular cables.
If you used wrong cables, you may have killed your drives.
I think I'm losing my mind here. It as been a long time since I built this PC, but I just looked at the power cables to my drives. I have 5 drives (including an optical) and they are daisy chained with power by 2 different cables. NEITHER of those cables end in a plug that would plug into a power supply. They just daisy chain the drives. How does that work?? I don't see how they're getting power and for the life of me I can't remember. They probably aren't getting any power now, but how did they get it before?
 

Warpspasm

Distinguished
May 28, 2003
355
0
18,780
0
OK. I got everything up and running. I decided I would take a chance and remove all of the power cables from my drives and use the ones that came with the new power supply. The system booted up fine and everything seems to running great.
Thanks!
 
Just a note, saw one person on here mixed cables when installing a new power supply and may have fried their graphics card(I think it was a 3080 or 3090 too), and possibly a motherboard. So NEVER EVER mix cables from different brands of power supplies. If you did, you are fortunate that all is working.
 

Warpspasm

Distinguished
May 28, 2003
355
0
18,780
0
Just a note, saw one person on here mixed cables when installing a new power supply and may have fried their graphics card(I think it was a 3080 or 3090 too), and possibly a motherboard. So NEVER EVER mix cables from different brands of power supplies. If you did, you are fortunate that all is working.
By the grace of God.
 

ASK THE COMMUNITY