Question I think something is killing my motherboards

ensei777

Prominent
Feb 1, 2021
24
0
520
1
Hi, for some reason lately I've been having to replace my motherboard, I've gone through at least 2 now, this time my pc just went full black screen after trying to use one of the front ports.. Should i just purchase i more expensive motherboard? my setup is:

CPU: Intel Core i9 9900K 8 Core LGA 1151 3.6GHz CPU Processor

GPU: TUF GAMING GeForce RTX 3080

RAM: corsair rgb vengance pro cmw32x4m4c3200c16W (using 2 of these not 4)

PSU: EVGA 750W SuperNOVA GA 80+ Gold Power Supply

MOTHERBOARD: Gigabyte Z590 UD AC LGA 1200 ATX Motherboard

Monitor: 360hz Alienware

I have XMP enabled to get higher frame rates in games, this might be causing some sort of issue, but every thread i've read says it couldn't damage your motherboard..

Would there be a combination of these components messing with my build? it runs very smoothly for a few weeks to months but then it seems to short out and i can't POST with no sign of life, i've had issue with the ram and possibly grounding in the past, but i'm not sure what could be causing this? any advice would be helpful
 

ensei777

Prominent
Feb 1, 2021
24
0
520
1
How old is the PSU in the above listed build? As for your black screening issue, have you tried reflashing the BIOS with the latest version and taking advantage of the QFLASH_PLUS button?
PSU is a few months old.
pressing power on won't do anything, no lights or anything, my mobo doesn't have a button but i updated the bios using qflash recently.
 

ensei777

Prominent
Feb 1, 2021
24
0
520
1
my mobo doesn't have a button but i updated the bios using qflash recently.

There's a white tactile button located exactly under the chipset's heatsink.
Oh, thanks I fully missed that thinking it would look like a previous q flash button i've seen, i'll have a go and get back to you
 

ASK THE COMMUNITY

Latest posts