• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question I tried to add new ram but now no display

xDarkN

Commendable
May 11, 2017
26
0
1,530
0
Hello I really need assistance please help me. I have h110m-r motherboard and i5 7500 cpu . I had 8 gb ram by Kingstone and added 8gb ram of hyper fury 2400 then after connecting everything I tried to turn on and no display appeared , so I tried to take off the new ram to check if without it the pc works and it still not showing display please help me and tell me what could it be 🙁 , I tried to look and check that all the cables are connected and seems they do
 

xDarkN

Commendable
May 11, 2017
26
0
1,530
0
omg it help thanks you! but now i have different problem. after my PC Turned on i see that i have still 8 gb instead of 16 whathappen? maybe i need to change smth in BIOS?
 

xDarkN

Commendable
May 11, 2017
26
0
1,530
0
i tried to connect each one by itself alone and both worked but when i connect both shows only 1 works . and on BIOS Its says that it recognize the 1st DIM But the 2nd N/A
 

xDarkN

Commendable
May 11, 2017
26
0
1,530
0
i understood that it shouldn't be a problem to mix 2 kinds of RAM Aslong they have the same DDR Which mine is DDR4 And both support. hmm the new one is Hyperx Fury 8 gb 2400 , and the old is Kingstone 2133 8gb
 

SierraArgo

Commendable
May 25, 2017
30
5
1,535
0
i understood that it shouldn't be a problem to mix 2 kinds of RAM Aslong they have the same DDR Which mine is DDR4 And both support. hmm the new one is Hyperx Fury 8 gb 2400 , and the old is Kingstone 2133 8gb
Mixing and matching RAM can be weird, and generally, it is best to avoid it. This is especially true imo when you are mixing RAM speeds because it throttles the faster RAM.
 
Reactions: xDarkN

xDarkN

Commendable
May 11, 2017
26
0
1,530
0
i know that its best to avoid but thats what i have atm and i think its suppose to work but need to do smth to fix it , please answers?

p.s i tried to clear the CMOS And turn on pc with both ram again but still.
 
I would try each module by itself in the slot that doesn't seem to work. You may not be able to get anything to boot this way, and if so, try putting the new module in slot 1 and old in slot 2. Mixing ddr4 can be quite tricky.
 
Reactions: xDarkN

xDarkN

Commendable
May 11, 2017
26
0
1,530
0
They may simply not be compatible no matter what you do.

Does your motherboard have the latest BIOS update? Some updates were issued to "Improve memory compatibility".
Well , i've updated the bios to the latest version and set them again to 2133 So both will be at the same speed but i still dont see the 2nd
 

xDarkN

Commendable
May 11, 2017
26
0
1,530
0
I would try each module by itself in the slot that doesn't seem to work. You may not be able to get anything to boot this way, and if so, try putting the new module in slot 1 and old in slot 2. Mixing ddr4 can be quite tricky.

I Did put the newer in slot 1 and the older in slot 2 and still. i will try to change their positions now , any more thoughts how to fix it please?
 

ASK THE COMMUNITY