Question I turned on XMP now my pc has BSOD for inaccesible boot device

Aug 23, 2022
3
0
10
0
MSi z 370 a pro
I5 8400
MSi gtx 1070
A data xpg ddr4 3000 4gbx4

I have been using this setup for 5 years no problem

I went to bios and turned on xmp tried to start and it kept resetting.

So I turned xmp off, it would still restart, so I reset the cmos, it would still just restart and now I have a BSOD for inaccesible boot device. And I would really appreciate any help, because now I wish I never touched the stupid bios.

edit: So I forgot to say that I can boot through the initial MSi start screen, I can access bios if I want and change settings. Past this it will do a restart, load through msi screen to BDSO where it asks if I want to restart or go to advanced options.
I can access advanced options, I can use command prompt.
I do not have a restore point or a file to restore from.
It will not allow me to uninstall latest updates, either option.
I do have a usb with the same windows on it, I can load this in advanced settings but cannot repair with it, seems like my only option there is to re install windows completely with it.

I have used command prompt to attempt to run scannow which did not work.
I tried dismm, did not work with an error code 87. I am currently running a chkdsk and waiting for results.
 
Last edited:

Karadjgne

Titan
Ambassador
Try booting the pc. As soon as windows starts to load, pull the plug, literally. Or turn the pc off using the psu power button, not the case power button. Do that 3x. On the 4th boot, it should take you to the repair/restore options. Choose Troubleshoot. Should be several options to repair. Don't choose the option to factory default or that basically wipes out any and all personal files/data.

Some motherboards do Not like 3000MHz ram, it's an oddball number. Back in the day, because of how speeds operated, 66, 133, 266 were the numbers of choice. Intel used them, amd used them, but Intel also used 50, 100, 200. To some small extent. Today's boards, the speeds are multiples of those bus speeds. Bus x multiplier x BCLK. 3200MHz would be 266 x 12 x 100.00. 2933MHz would be 266 x 11 x 100.00. 3000 is the oddball, it's the only standard speed ram using 200 x 15 x 100.00, every other ram uses 266Hz base because it means a smaller multiplier, which is more stable.

If you do get this fixed, and want the advantages of the higher speed ram, enable XMP but manually set the frequency to 2933MHz instead.
 
Last edited:
Aug 23, 2022
3
0
10
0
I did as you said with no change.

so here’s what I did.
I really didn’t have much on the drive just a couple games and some software. So I went to go format and re install windows, however it would not let me due to the drive being in something called gtp format and that being incompatible with uefi.
The only change I made today was the xmp and following that updating my bios for the first time in 5 years lol. I’m guessing that set my bios to uefi instead of legacy bios and I missed that during my panic and that’s was causing my BSOD.

i followed a guide to format my disk through command prompt to the correct formatting for uefi and it worked. I’m booted up and installing all my old stuff.
 

Karadjgne

Titan
Ambassador
Win10 and prior tied their format to installation type. Basically Windows could not install to GPT drives under UEFI.

Drives are either GPT or MBR. MBR is ancient, seriously ancient, but it works. Also has limits 4 partitions, 2Tb max since it's that old. MBR keeps all drive info in 1 spot at the front of the disk. GPT is essentially unlimited. Keeps a list of partitions at the front, but each partition info is kept at the front of the individual partition. NVMe run better with GPT. Win11 requires GPT, UEFI only, Secure Boot.

CSM is legacy compatibility which disables Secure boot, takes Legacy + UEFI to use.

So to install Windows 10 and prior, bios is set to OtherOS (not WindowsUEFI). It defaults to MBR format. It's a process to change that to GPT once done unless during initial install you specify UEFI installation. Once boot records are set in Windows for MBR, if you change the drive to GPT, you'll get issues. The drive (for instance) now speaks Chinese but Windows was installed in English, so there's stuff that gets lost in translation.

It's kinda confusing and a real pain to sort out if you miss just one setting, like changing from OtherOS to WindowsUEFI.
 
Aug 23, 2022
3
0
10
0
I think I understand lol, definitely a lot to take in.
i did put my drive in mbr to allow the windows install and everything is working good now, I am going to create a back up this time for sure lol 😂
 

ASK THE COMMUNITY