Question I upgraded CPU and cooler but PC is running slower - - - why is that ?

Jun 30, 2022
1
0
10
0
Hi im swaz i recently (yesterday) upgraded my cpu and cooler from a AMD Ryzen 5 3600 with stock cooler to a AMD Ryzen 7 5800 with the NZXT Kraken Z73 RGB 360mm and i installed everything correctly and i turn my pc then everything is running so slow, i can open task manager, my settings, and my web browser but i cant go into links it says the web is not responding. i researched the problem, ive done so far
My current specs
• Ryzen 7 5800X
• rx 5700 xt Thicc III
• Gigabyte B550 Aorus Pro Ac
• Corsair vengeance LPX 16 GB DDR4 3600
(i forgot to mention that i updated my bios to the recent one “F15c” and updated my drivers)
(i forgot to mention that i updated my bios to the recent one “F15c” and updated my drivers)
  • Cmos reset (which i think i did right i took the motherboard board battery out for 10 mins and put it back it)
  • reinstalled windows and deleted everything basically
  • i checked thermal paste and put more bc the pre applied one seemed a little less to me
I need help asap im starting to lose hope….
 

Colif

Win 11 Master
Moderator
Jun 12, 2015
56,517
4,471
160,690
10,205
do you have latest chipset drivers?
https://www.amd.com/en/support/chipsets/amd-socket-am4/b550
Do you have latest LAN drivers -
if you on win 10, download Win10 Auto Installation Program (NDIS) from under the windows header
If you on win 11, download Win11 Auto Installation Program (NetAdapterCx) from under the windows header here
https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software
what storage drives do you have?
 

ASK THE COMMUNITY

TRENDING THREADS