Question i vaccumed my hard drive and now my pc doesnt recognize it anymore. what should i do?

Jul 11, 2021
4
0
10
0
i vaccumed my whole pc today because it was quite dusty. i was careful when doing it and my pc was turned off at that time.
after turning it on my pc could not recognize my hdd. i read online that it could be a problem to vaccum the hdd because of static etc.
i really need my hdd as it stores all of my university documents that i need pretty soon for exams.
did i completely destroy my hdd? is my data still on it? how should i proceed?
help is much appreciated.
 
Jul 11, 2021
4
0
10
0
Try the drive in another pc or put it in a caddy and connect it to another pc. If it still is not recognised then unfortunately I would say it is dead.
hello thank you for your help. unfortunately theres no other pc around that i could try it on and im not sure what a caddy is. do you have any other ideas?
 
Jul 11, 2021
4
0
10
0
I would first suspect a loose cable.

But this is a good time to talk about the backups you made before this happened....;)
i will try to plug the hdd in with a different sata cable maybe, is that a good idea? and unfortunately i did not backup my data because i dont have any spare harddrive
 

USAFRet

Titan
Moderator
Mar 16, 2013
144,775
8,702
175,340
22,588
i will try to plug the hdd in with a different sata cable maybe, is that a good idea? and unfortunately i did not backup my data because i dont have any spare harddrive
Different cable, different SATA port.

What specifically happens when you power up?

What are the specs of this system?

i did not backup my data because i dont have any spare harddrive
Episodes like this are specifically what backups are for.
 
Jul 11, 2021
4
0
10
0
Different cable, different SATA port.

What specifically happens when you power up?

What are the specs of this system?


Episodes like this are specifically what backups are for.
Hello there, sorry for the late response. In the meantime i bought a new hdd which is as far as i know the same as the old one.
when i opened the bios though, it showed that there was nothing conncted to any of the sata ports even though i actually connected both harddrives (even though one might not be working).
could it be a motherboard issue? or an issue with the sata cables maybe..
my specs are: https://pcpartpicker.com/list/dTVWfP

Thank you for your help in advance.
 

ASK THE COMMUNITY

TRENDING THREADS