[SOLVED] i3-10100 no display on AMD GPUs ?

Jan 18, 2022
So I'm upgrading a Biostar A10-8800N rig with RX 470 to an Asus H510M-K and an i3-10100.

Whatever I try, I just can't seem to get display from the RX 470 on the upgraded platform. The iGPU works, and surprisingly a GTX 1650 Super works. But the RX 470 wont give display no matter what. However, the RX 470 works on my other i5-8600K rig and the prior A10-8800N rig.

Here's what I've tried:
  • Changed to another H510M board (Gigabyte H510M H and MSI H510M Bomber) (no display on RX470 but works on iGPU/1650S)
  • Changed the i3 10100 chip to another i3 10100 (no display on RX470 but works on iGPU/1650S)
  • Changed the board with H410M (no display on RX470 but works on iGPU/1650S)
  • Changed the GPU to an R9 390X (no display on R9 390X either!)
  • Changed to GT 520, works fine.
  • Set primary display to PEG in bios.
  • Tried a 850W PSU just to make sure it wasn't a PSU related issue. Same results
  • Updated Motherboard bios. No issue.
So in short, the i3-10100 and H410/510 doesn't want to give display on AMD GPUs, specifically on RX 470. Is there anything I'm missing?
Also, do note that the system is booting up with the AMD GPU installed. The leds on keyboard turns on and Numslock/Scrollock responds. But just no display.

Also, later I got a feedback from the vendor I got the MSI H510M from that 11400 is giving display on both AMD and Nvidia GPUs.
It sounds like you have eliminated most of the obvious things...

I have heard of some weird issues with AMD cards being fussy about which specific display output you use on initial startup, what type of cable are you using, have you tried any other outputs on the AMD card on the new rig? Another question, have you tried the igpu output when the machine boots with no display? If that works I'd suggest looking in device manager in Windows and see if the card is identified or not.

The bios mode you are using can also be important, AMD dropped support for legacy bios some time ago and only supports UEFI - some motherboards still offer both so might be worth checking the settings and make sure its in UEFI mode whilst running on the iGPU (I would be surprised if this is the issue in 2022 but worth checking).