Question I3 9100F only getting 30FPS?

Apr 6, 2020
5
0
10
0
I have recently built a new pc.
It has a I3 9100F, 2*4GB 2133Mhz, Rx 470 8GB, H310M PRO-VD, A old power supply from my old system. + 1TB hard drive which used to be host of a FX 4130 and hasnt been wiped.
My system is only getting low 40's/high 30's FPS in battlefield 1 low settings and 60 in battlefield 4.
I know the I3 isn't great but I've seen many youtubers get at least 60 fps on any game, it 80 on battlefield 5 ultra settings.
I know the i3 is the problem as in task manager I always during the smallest load have 100 percent cpu usage with all other applications closed while the RX 470 8gb only goes to 40 percent usage. Is there some i3 driver i missed? Ram only maxes out at 5gb during games - it is dual channel.
People with near identical systems get over 90 on decent settings at battlefield 1. The one possible option i thought of is the CPU not getting enough power. The 8 pin cpu power connector is only being supplied by a 4 pin. And it turbos to over 4GHz? But if it did not get enough power it would just shut down. Or could it be a problem with the motherboard. Later tonight or tomorrow i'll install msi after burner and a cpu bench mark. But I would like to hear your thoughts.
 
Apr 6, 2020
5
0
10
0
I haven't gave windows a fresh install. I know my cpu temps are low as after trying to play bf1 i went into bios and it said cpu temps were 40 degress. I'm install msi after burner right now. I should have some better data soon.
 

Zizo007

Respectable
Feb 23, 2019
1,653
229
2,290
55
I have recently built a new pc.
It has a I3 9100F, 2*4GB 2133Mhz, Rx 470 8GB, H310M PRO-VD, A old power supply from my old system. + 1TB hard drive which used to be host of a FX 4130 and hasnt been wiped.
My system is only getting low 40's/high 30's FPS in battlefield 1 low settings and 60 in battlefield 4.
I know the I3 isn't great but I've seen many youtubers get at least 60 fps on any game, it 80 on battlefield 5 ultra settings.
I know the i3 is the problem as in task manager I always during the smallest load have 100 percent cpu usage with all other applications closed while the RX 470 8gb only goes to 40 percent usage. Is there some i3 driver i missed? Ram only maxes out at 5gb during games - it is dual channel.
People with near identical systems get over 90 on decent settings at battlefield 1. The one possible option i thought of is the CPU not getting enough power. The 8 pin cpu power connector is only being supplied by a 4 pin. And it turbos to over 4GHz? But if it did not get enough power it would just shut down. Or could it be a problem with the motherboard. Later tonight or tomorrow i'll install msi after burner and a cpu bench mark. But I would like to hear your thoughts.
Why don't you use the 2x4pins and only 1x4pin?
 
Which mode of Battlefield are you playing? The single player campaign and the smaller maps are not very CPU heavy, but the 64 player maps will absolutely slaughter a current i3 as Battlefield 5 really needs more than 4 threads to run well on those large maps. One thing to keep in mind with Youtube benchmarks is they often use canned benchmarks or test in single player campaigns to get more consistent results. Problem is the cracks don't start to show on the i3 in Battlefield until you hit those 64 player maps.
 
Apr 6, 2020
5
0
10
0
Which mode of Battlefield are you playing? The single player campaign and the smaller maps are not very CPU heavy, but the 64 player maps will absolutely slaughter a current i3 as Battlefield 5 really needs more than 4 threads to run well on those large maps. One thing to keep in mind with Youtube benchmarks is they often use canned benchmarks or test in single player campaigns to get more consistent results. Problem is the cracks don't start to show on the i3 in Battlefield until you hit those 64 player maps.
It's only battlefield 1. And I just tried a 10 v 10 with also no luck and no performance change.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS