i5 2500k non overclockable motherboard

holley.deondre

Prominent
Aug 22, 2017
164
0
680
0
I just bought a r9 390x and my fx8350 bottlenecks it. I’ve seen an intel i5 2500k does not. But I’m on a tight budget and need the motherboard and cpu fast so my only option right now is the motherboard from the hp elite 8300. Is the intel i5 2500k stock good enough not to bottleneck the r9 without any Overclocking? I never overclocked my fx anyways.
 

holley.deondre

Prominent
Aug 22, 2017
164
0
680
0
I’m not Overclocking anything. I have a 650w and a sabertooth 990fx r2.0. I5 2500k is way better than the fx I have. I’m asking if I don’t overclock it leave it stock will it help my bottle neck issue
 

k1114

Titan
Moderator
Youtube is one of the worst places to get correct info when it comes to pcs. Everything isn't right if it's shutting down or freezing. If you just copied settings that someone else used then that's 100% wrong. You don't have their pc and their settings won't work for your pc even if it's the exactly the same models. Have you made a thread to get help ocing?
 

holley.deondre

Prominent
Aug 22, 2017
164
0
680
0
No I haven’t but if it’ll help me then I will. I’ve got it to be stable at 4.5ghz with a 15 hour stress test on amd over drive but I forgot what voltage I set it at. I have no problem trying again since I have a great motherboard I just need tips and guidance
 

holley.deondre

Prominent
Aug 22, 2017
164
0
680
0
Not stock hyper t4 I got it to a stable 4.4 stock voltage with 56 Celsius under load. 4.5ghz went to over 70 but was stable I’ve tried under volting but got a blue screen and my motherboard said overclocking failed
 

holley.deondre

Prominent
Aug 22, 2017
164
0
680
0
If you guys can help me get to 4.5 or 4.6 I’ll deff listen and try it out. Back when I tried it on amd over drive I got it to 4.5ghx stable for hours and 4.6ghz when I went to bed but when I got up it’ll say test failed but i really want to do it via bios so it’s always running at that speed. Also if you guys know my ram is rated 1600mhz but when I put it at 1300 MHz it’ll freeze my pc or when I do 1600mhz it’ll only read 4gb Ram instead of 8gb
 

holley.deondre

Prominent
Aug 22, 2017
164
0
680
0
Oh okay I’ll try to do the 4.5 again but it was honestly going at 75 and went up slowly and it was only 10 minutes in. I’ve seen 8350 shouldn’t go over 65 under load can you confirm? I’m usually sitting at 30 idle and now 55ish load
 

holley.deondre

Prominent
Aug 22, 2017
164
0
680
0
It’s been a few hours prime 95 and hwm 4.5ghz 1.28v but I noticed after awhile some cores aren’t fully at 100% after about an hour for example at one point cores1-4 were at 100% while the rest was at 1% or 0% now I see 1-4 100 5,6, at low flucating % 7 at 100 and 8 at a high fluctuating %. What could this be? But so far no freezing or blue screen

Temp was 28-30 idle 43 under load and highest was 56
 
That seems very reasonable. As for why you have such core utilization that could be a lot of things. First check all the application settings. I'm on a phone or I'd look at the computer myself and check the settings. I'd say try gaming and see where you go from there.
 

ASK THE COMMUNITY