Question i5 7600k max usage in games

Mar 6, 2020
1
0
10
0
Hi, I'm using an i5-7600k and it has been running 100% on all my games. I am playing rocket league, R6 Siege, and others. It reaches 100% and I cannot talk to friends because of this, and sometimes it doesn't register my input from my keyboard or mouse. It also lags my game. I checked for updated drivers and could not find anything. I am running a i5 7600k, gtx 1080ti, 16 gb 3000mhz ram, cpu temps are in the 60s when playing, and is have a msi z270 sli plus motherboard, 4 tb seagate hdd and 512 gb samsung 960 M.2. I have no idea why it's doing this. It just started doing this a week ago. Just a couple months ago it was perfectly fine. I tried turning all my setting down to off or low for all graphical or cpu intensive tasks. Please help. I was looking at getting a new intel or a ryzen, but I really want to save money because I am in college and need to pay rent.
 
I tried turning all my setting down to off or low for all graphical or cpu intensive tasks.
That's the exact wrong way to go about this,the 1080ti is a powerful card and decreasing settings will only increase the possible FPS making the CPU work even harder.
You should increase settings as much as possible,if you have a 1080 monitor consider using DSR on nvidia control panel to run games at 1440,you want to decrease the possible FPS to something that your CPU can easily handle.

A different way to go about this is to use task manager to decrease the priority of the game or to increase the priority of your background tasks like discord or whatever you use to talk to your friends.(Although this could also be caused by your internet being hammered and not being able to communicate with the server)
 

boju

Champion
Ambassador
Try limiting your frame rates to a level where the cpu isn't trying to prepare so many, consuming too much cpu. Can use Afterburner or Nvidia Inspector to limit fps if games don't have an built-in limiter. Try around 60 and monitor cpu usage and work your way up to a level your comfortable with.

Might also try move Discord to another least busiest core using affinity in Task manager. Cortana can take away some cpu, so maybe try disable it.

Quads are known to struggle so try keep background apps to a minimum and try limit fps.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS