Question i5 8300h power throttling when nvidia gpu runs (only)

Nov 15, 2020
10
0
10
0
So I have an Asus tuf fx504ge laptop. I'm facing power limit throttling to 25 watts whenever the Nvidia GPU kicks in (video or gaming no matter what). When the Nvidea GPU is on idle it uses iGPU and was able to go above 40 watts (and 50 above for a short period of time) even when stress testing in the XTU (CPU stays always above 3.8 GHz and 100% load and power always above 40 watts).

So this throttling problem starts as soon as the Nvidia GPU runs from idle (even when the GPU load is 2% and low frequency), I can accept if it throttles at max frequency and full load because the power brick may not enough. But do you think 120w brick isn't enough for i5 8300h and 1050 Ti mobile? I don't think so, because I saw few benchmarks on youtube for the same CPU and GPU but from Acer brand (Acer Nitro 5), that Acer nitro 5 has the same hardware and managed to keep CPU at 3.9 GHz without throttling but I saw many people having this problem with most of Asus TuF series.

Is there any way to fix this problem. I had already tried a few things and tested and none of them worked and I'll list them below.

Undervolted - nope it didn't fix the issue but managed to keep up with temps. Oo I forgot to mention that even during heavy gaming the GPU temp didn't go above 60 C and CPU temp around 65 C, this CPU throttles at 88 C only.

Tried locking the voltage and frequency of GPU - Nope.
Maxed out the Icc index - didn't fix the problem.
Tried disabling Turbo Boost Short Power Max - didn't fix.
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Have you tried inspecting the internals of the laptop to see if the cooling assembly needs cleaning or maybe a reapplication of thermal paste and if the mounting is secure, often times an improper fit can cause that issue. Asus's support site isn't working for me today, mind scoping out which BIOS version you're on at the moment?

Version of Windows 10 that you're currently working with?
 
Nov 15, 2020
10
0
10
0
I'm on BIOS version 318 there is a new version 320 but in that many reported Asus locked voltage control of CPUs causing more heat and thermal throttling so I didn't update that since it'll worsen the situation more.

Well, regarding the temps it's way better on my system. I always keep the internal clean from any form of dust and I had also replaced the stock thermal paste with a high-performance one and it really doing a job in keeping thermals always below 60 for GPU and 65 - 68 for CPU. Even in the stress test it never went above 70 C. So thermal wise no issues for sure.

Windows 10. 2004 version and 19041.508 build number. I had verified all other components like SSD and ram and all are working like new and no issues or whatsover.
 
Nov 15, 2020
10
0
10
0
To add more info to the question, here is the screenshot



As you can see it has power limit throttling even when there is no intense 3D task for Nvidia GPU. I just ran the MSI afterburner and opened the Nvidia control panel, these two triggered to run GPU from Idle and then as you can see it throttles to 25 Watts.



And as you can see here, as soon as I close the apps that cause to run the Nvidia GPU, the power limit was gone even with the full CPU load. screenshots in this reply taken in 5 mins difference and nothing did except closing MSI Afterburner and Nvidia control panel.

Edit reason: added screenshots.
 
Last edited:

lga1156_ftw

Notable
Feb 25, 2020
1,211
132
1,190
95
If you have somekind of software based fan control (usually locked in asus bios for laptops) , try using the "overboost" or "Turbo" setting for fan control. This might disable the throttling. There also could be fn key combination

EDIT: you can try finding it in bios, there might be fan mode settings
 
Nov 15, 2020
10
0
10
0
Yes, there's a fan control low + medium + overboost. I always use overboost mode.

@lga1156_ftw but I noticed one thing that whenever the throttling starts after GPU kicks in, if I switch the fan profiles randomly then the throttle flag goes for a few moments.
 
Last edited:

lga1156_ftw

Notable
Feb 25, 2020
1,211
132
1,190
95
I looked into it and seems like it has been capped to 25w in the bios when nvidia gpu is being used, either that or power brick.

You might be able to test if its the power supply by undervolting cpu slightly and gpu more in afterburner, if you get more than 25w with nvidia gpu under load then it might be the power supply.
 
Nov 15, 2020
10
0
10
0
I looked into it and seems like it has been capped to 25w in the bios when nvidia gpu is being used, either that or power brick.

You might be able to test if its the power supply by undervolting CPU slightly and GPU more in afterburner, if you get more than 25w with Nvidia GPU under load then it might be the power supply.
I'll try locking the frequency and voltage in the MSI afterburner and will test.
 

lga1156_ftw

Notable
Feb 25, 2020
1,211
132
1,190
95
With throttlestop you can also undervolt cpu core , cache and iGPU, if your using very low values for this test you might try increasing them. Like -125mv for cache, igpu and core in Throttlestop.

Do not overclock the gpu core or memory in afterburner when testing this. You actually need to decrease the max frequency so you can hit low enough voltage, If you go too low voltage with too high frequency you will crash and might get black screen when booting to operating system, to dodge this untick the windows logo under "startup" in afterburner which makes it start every time you open windows, you can untick it in settings too. This means your undervolt dont apply when booting if you crash and dont need to manually uninstall afterburner in safe mode.

Keep the "BD PROCHOT " ticked as in your case this is safety measure and is not causing this
 
Last edited:
Nov 15, 2020
10
0
10
0
With throttlestop you can also undervolt cpu core , cache and iGPU, if your using very low values for this test you might try increasing them. Like -125mv for cache, igpu and core in Throttlestop.

Do not overclock the gpu core or memory in afterburner when testing this. You actually need to decrease the max frequency so you can hit low enough voltage, If you go too low voltage with too high frequency you will crash and might get black screen when booting to operating system, to dodge this untick the windows logo under "startup" in afterburner which makes it start every time you open windows, you can untick it in settings too. This means your undervolt dont apply when booting if you crash and dont need to manually uninstall afterburner in safe mode.

Keep the "BD PROCHOT " ticked as in your case this is safety measure and is not causing this
So I tested by setting the frequency at 1480 MHz on the afterburner and locked it with 900 mv and it was stable during the gameplay. But for CPU yes I undervolted to its maximum performance level. For few mins, it goes above 25w when switch fan profiles (will leave it at overboost mode) after a few mins or seconds it starts to throttle again. I also noticed it is throttling even when there is no heavy load on the GPU (throttles at even 5% GPU load).

I would like to mention the temps, those are actually great never went above 70 C.
 

lga1156_ftw

Notable
Feb 25, 2020
1,211
132
1,190
95
Well atleast its not temperature related, You can try go even lower like 825-800mv but remember to decrease freq to 1400Mhz or lower. Also untick the start with windows cause you can expect crashes going so low voltage.
If you then get stable above 25w it actually might be the power supply limit. Did you also undervolt cpu cache and igpu or only cpu core?
 

lga1156_ftw

Notable
Feb 25, 2020
1,211
132
1,190
95
Have you already tried disabling intel dynamic thermal?



You can try both.
 
Nov 15, 2020
10
0
10
0
Alright, with 800ish mV (don't know selected between 850 and 875mV but in GPU-Z it is showing 800mV) and 1430 MHz it kept the TDP above 28w all the time during 20 mins gameplay.
 

lga1156_ftw

Notable
Feb 25, 2020
1,211
132
1,190
95
It actually might be the power supply after all, but its about 50% or less chance that it will help. Best thing would be to test with 180w power supply (dont buy 150w might be same issue) and if you see improvement then buy it. 180w asus power supplies are expensive.

Other option is to just keep tweaking the voltage and frequencys until you hit sweet spot for performance and stability. If you disabled DPTF (it can reinstall itself) and power limits in throttlestop and still have this issue it might be locked in the bios.

I dont suggest modified bios with laptops since these can cause bricked motherboard. Power supply worth a try, buy after testing if it works and if it doesnt then try to find the sweet spot with lowering voltages.
 
Reactions: pcloverbutnomoney
Nov 15, 2020
10
0
10
0
Alright, I guess I'll try find the sweet spot with afterburner. Anyway what DirectX API you'll recommend? 11 or 12 (I play GTA V (11), Fortnite (12 Beta) and modern warfare)
 

ASK THE COMMUNITY

TRENDING THREADS