[SOLVED] i7 87000 (non k) stuck at 4.3GHz

Techxz

Reputable
Dec 22, 2015
59
0
4,540
1
I have an i7 8700 and a gigabyte z370 aurous gaming 5 motherboard and for some reason the CPU frequency is always stuck at 4.3GHz.

Normally, unless I am using an overclocked CPU, the CPU frequency is very low when I am using the computer for basic tasks and only turbos when I am gaming, but this one seems to be stuck always stuck at 4.3GHz. I don't like this because my temperatures are high and my fans spin loudly as a result.

Anyone have any ideas as to what I can do?
 
Are most CPU multiplier-related settings in the BIOS at default/auto, or were/are assorted BIOS settings perhaps left set for overclocking (max vs. Auto, etc.?) from earlier CPUs...? (Windows power management set to Balanced?)
 

Techxz

Reputable
Dec 22, 2015
59
0
4,540
1
Are most CPU multiplier-related settings in the BIOS at default/auto, or were/are assorted BIOS settings perhaps left set for overclocking (max vs. Auto, etc.?) from earlier CPUs...? (Windows power management set to Balanced?)
I have reset the bios to the factory default settings, so I assume it's all on auto.
 
If you are absolutely certain nothing is running (some folks pick up crytptocurrency miner/malware), then you need to go thru every setting in the BIOS and doublecheck...(if something were running, often it shows in task manager as an unexplained process causing lots of CPU usage)

Also make sure WIndows 'power plan' is set to 'Balanced'...

Install/launch HWMonitor to monitor actual core speeds change, where the application updates twice/second....

(Any chance you installed and were tinkering with Intel Extreme Tuning Utility in the past?)
 

Techxz

Reputable
Dec 22, 2015
59
0
4,540
1
If you are absolutely certain nothing is running (some folks pick up crytptocurrency miner/malware), then you need to go thru every setting in the BIOS and doublecheck...(if something were running, often it shows in task manager as an unexplained process causing lots of CPU usage)

Also make sure WIndows 'power plan' is set to 'Balanced'...

Install/launch HWMonitor to monitor actual core speeds change, where the application updates twice/second....

(Any chance you installed and were tinkering with Intel Extreme Tuning Utility in the past?)
The "balanced" power plan settings in windows have changed it back to varying cpu frequencies, so thank you for that, but the max clock does not go above 4.3GHz instead of the 4.6GHz that the 8700 is supposed to achieve. Any idea on what I can do?

Also, I have not installed I.E.T.U on this PC.
 
Apr 20, 2019
4
0
20
1
The reason why it does not go above 4.3 GHz is because the max frequency of 4.6 GHz is achieved only when using 1 core.
1 core: 4.6 GHz
2 cores : 4.5 GHz
3 cores : 4.4 GHz
4 cores + : 4.3 GHz
So this is normal.
However, the CPU should not stay at that speed when idle or doing light work. What is the CPU usage? Is always 100% it would mean that some process is using CPU time, if not, it really looks like the power settings are not set on Power saving mode
 
Apr 20, 2019
4
0
20
1
Just to make sure, got to Settings > System > Power & Sleep, then click on "additional Power settings".
There "balanced (recommended)" should be checked. Then click on the "change plan settings" link on the right of "balanced (recommended)". In the new window, click on "change advanced power settings" which brings the power option window.
Scroll down to "Processor power management > Minimum processor state
this setting should be around 5% and I suspect for you it is set at 100%.
 

Techxz

Reputable
Dec 22, 2015
59
0
4,540
1
Just to make sure, got to Settings > System > Power & Sleep, then click on "additional Power settings".
There "balanced (recommended)" should be checked. Then click on the "change plan settings" link on the right of "balanced (recommended)". In the new window, click on "change advanced power settings" which brings the power option window.
Scroll down to "Processor power management > Minimum processor state
this setting should be around 5% and I suspect for you it is set at 100%.
I have done that but for some reason every time I restart my system it goes from the balanced power option back to the performance power option. Also, I don't ever go higher than 4.3GHz even on one core.
 
Apr 20, 2019
4
0
20
1
You might want to try to reset and restore your power plans to default setting. I'm not sure that's gonna change anything but it's worth trying.

Open a command prompt as administrator, then type in (or copy/paste from here) this line:
powercfg -restoredefaultschemes


For the max frequency, it is very difficult to get single core performance as the computer (and windows 10) are very good at using multi-cores. If you run HWMonitor in the background while using your computer for different task and look at the Max values obtained for your CPU cores Clocks, you "should" seeat least some core hitting frequency closer to the 4600 MHz... If not, this might be due to the same problems that prevent you CPU to run at lower frequency when idle.
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS