Question i7-9700F Performance Issues.

yaboibaron

Reputable
Oct 12, 2017
89
3
4,535
0
Hello! I have an i7 9700F, 2070 super, 16gb ddr4 3000 mhz ram and have run into a wall. This game I play is quite cpu intensive. and my friend who has an i7-8700k gets almost 80 frames over me and he only has a 2060 super. What could be causing this do you think? Ive updated bios, chipset, and have xmp on my ram. ive done almost every tweak and am just lost. could it be my cpu? Its boosted to 4.4mhz in game too. im just baffled.
 
Assuming your temps are under control (and I doubt there'd be any extensive cooling headroom with a factory cooler) I'd at least try to over-rule the TDP power/duration of time in full turbo constraints, and, possibly even full turbo for all cores via Intel's XTU...(although 4.5 GHz all-core turbo is likely near the non-k series CPU's max, as they were not intended/sold to clock quite as high as the K or KF series of CPUs..)
 

yaboibaron

Reputable
Oct 12, 2017
89
3
4,535
0
Assuming your temps are under control (and I doubt there'd be any extensive cooling headroom with a factory cooler) I'd at least try to over-rule the TDP power/duration of time in full turbo constraints, and, possibly even full turbo for all cores via Intel's XTU...(although 4.5 GHz all-core turbo is likely near the non-k series CPU's max, as they were not intended/sold to clock quite as high as the K or KF series of CPUs..)
Assuming your temps are under control (and I doubt there'd be any extensive cooling headroom with a factory cooler) I'd at least try to over-rule the TDP power/duration of time in full turbo constraints, and, possibly even full turbo for all cores via Intel's XTU...(although 4.5 GHz all-core turbo is likely near the non-k series CPU's max, as they were not intended/sold to clock quite as high as the K or KF series of CPUs..)
Is Intels "Boost technology" not that great? I have a hard time believing that my cpu being boosted to 4.5ghz is not beating a cpu that is only clocking to 4.3ghz via the same method. something just isnt adding up and idk why
 

ASK THE COMMUNITY