Question I7 9700K High % Usage in Game and Tasks? Help ?!

Aug 18, 2020
3
0
10
0
Hey.
So first of all my specs...
CPU - Intel i7 9700k
Motherboard-ROG STRIX Z390-E GAMING
GPU - NVIDIA GeForce RTX 2070 Super (msi trio)
RAM - 32GB Corsair Vengeance RGB Pro
PSU - Evga 750w 80+ gold
Cpu Cooler- NZXT Kraken x62

Few days ago i got gifted a new ram set (the one in the specs),
as soon as i booted my pc up with the new ram i started getting high usage issues in idle mode and in game.

While in game my cpu is reaching 100% while my gpu is doing fine, tempretures are normal its just the usage, as soon as it hits that 100% usage my fans start going crazy loud and fast.
i have no idea how this happened i never had any issues like this and it started happening as soon as my new ram was in.

(Also since then my keyboard does not work in games ?! if i could get any help that would be great)
 

Turtle Rig

Prominent
Jun 23, 2020
769
103
590
13
Your losing out with the 9700k as it doesn't have hyperthreading. Your missing 8 vital threads that can help give your CPU 40 to 60 percent usage and give a 35 percent in boost in performance not in games but in desktop apps and what not as games don't really support HT right now. This has nothing to do with a RAM change. Just to make sure go to BIOS and set everything to optimized defaults or restore defaults. Then boot up and see what the CPU usage is and what not. But gaming wise I wouldn't be surprised if it pegs as its missing 8 threads however you still shouldn't peg, but depends on the game. Your video card pownz so that is not the problem. As I said do a restore defaults on BIOS then worst case scenario configure your RAM manually in BIOS. Not X.M.P instead put the ram speed then the voltage which is right on the Kits box and the timings for both channels and then give her a shot. Good Luck 🧑🏽
 
Sep 17, 2020
2
0
10
0
Hey.
So first of all my specs...
CPU - Intel i7 9700k
Motherboard-ROG STRIX Z390-E GAMING
GPU - NVIDIA GeForce RTX 2070 Super (msi trio)
RAM - 32GB Corsair Vengeance RGB Pro
PSU - Evga 750w 80+ gold
Cpu Cooler- NZXT Kraken x62

Few days ago i got gifted a new ram set (the one in the specs),
as soon as i booted my pc up with the new ram i started getting high usage issues in idle mode and in game.

While in game my cpu is reaching 100% while my gpu is doing fine, tempretures are normal its just the usage, as soon as it hits that 100% usage my fans start going crazy loud and fast.
i have no idea how this happened i never had any issues like this and it started happening as soon as my new ram was in.

(Also since then my keyboard does not work in games ?! if i could get any help that would be great)
 
Sep 17, 2020
2
0
10
0
hey did you find a fix i have same gpu msi rtx 2070suoer gaming x trio and i7 10700k i just got the pc it was fine for 2 weeks than last night it did this after playing some csgo for 20mins or some wz for some little time the fps drops from 200 to 70 and in cs from 400 to 100 but temps are good both on cpu and gpu and the cpu usage is 100% the moment the fps drops so could u inform what did u do.
specs
rtx 2070 super gaming x trio
i7 10700k + antec a400 air cooler
16gigs of vulcan z 3200
msi mpg gaming plus z490
pny ssd nvme 250gigs
1tb of baracuda
antec 850 w high current gamer 80+ gold
 

ASK THE COMMUNITY

TRENDING THREADS