Question i7 9700k Turbo Boost 4.9GHz on all 8 cores

Mar 26, 2019
To all Intel geeks,
is it possible to get 4.9Ghz on all 8 cores on a i7 9700k in Turbo Boost? HWMonitor was showing it for like 2 minutes in a row and it's not the first time (see screenshot).
I have an ASRock Z390 Extreme4 with default settings, no OC mode on.
Mar 26, 2019
that just the max for the from since you turn the PC on. doesn't mean it running at max currently.
Please refer to the screenshot I posted. The first column is the actual value whereas the third one is the max. The actual value on all 8 cores is 4900MHz.
With MCE (Multi Core Enhancement) enabled in the BIOS, and adequate cooling, the mainboard will attempt to run it at all cores on max turbo, which for the 9700K is indeed 4.9 GHz... (Perhaps your MCE option in the BIOS came defaulted to on/enabled, same as Asus used to do....)
go into windows power options and switch to balanced. then set your cpu to max 100 and min 0 your cpu should throttle back to 3.5 or less.
if it then jumps up to 4.9 on all cores without you doing anything. then check task manager for a process using 100% cpu.
Intel's intended default behavior is for only 1-2 cores to go to max turbo, 3-4 cores at full active is 100 MHz less, and finally ending with the default condition of where when 8 cores are active, the clock ispeed is like 4.6 GHz or so; tinkering with WIndows power management will in no way override this, and only the MCE BIOS option will, unless manually tinkering/specifying fixed multiplier options. (When/if MCE is an option and is enabled with adequate cooling, it works very well, and seems a great idea, as the CPU can still idle under no load at normal 20-40 watt power draw at 800-1000 MHz, and only increase to the high clock speeds when under rendering or gaming loads. Not sure who would remotely want to sit at 5 GHz constantly, just to read forums, watch Youtube, etc...)

In short, If you see all cores going to 4.9 GHz, then someone has either set the multiplier manually, or... MCE is enabled. (As Asrock is an Asus-subsidiary, one can be almost certain MCE is at work)


Apr 13, 2018
No apply here.

" MCE is locking all-core to the single-core Turbo speeds .Usually when XMP is enabled, the CPU is told to use the top turbo boost setting under all loads. That means a CPU like the i7-3770K has only two speeds – 3.9 GHz while under CPU load, and 1.2 GHz at idle."


I have the power settings I mentioned and No low idle speed and No MCE enabled in EUFI. MCE is set to " auto-let bios decide" , other settings are on/off.

If it were on, then there would be a low idle, but not here. And I manually set dram speed..Do you talk from experience ?